0
$\begingroup$

Rosanswers logo

Hi,

I installed openni to work with a Kinect on a Debian Squeeze. I followed the instructions in http://www.ros.org/wiki/openni_kinect to build and install a package for debian, and after that I used the openni.launch to start working with kinect, but I get a message of "No devices detected".

The kinect seems to be detected by the system if I do lsusb (xbox NUI Motor?).

Can anybody help me? Thanks.

lsusb
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 045e:0752 Microsoft Corp. 
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 001 Device 003: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 002: ID 041e:4083 Creative Technology, Ltd Live! Cam Socialize [VF0640]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The result of the launch is:

    roslaunch openni_launch openni.launch
... logging to /home/toni/.ros/log/d5cdbf70-0472-11e1-9ff1-bcaec5bdea73/roslaunch-hugoros-3696.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
WARNING: disk usage in log directory [/home/toni/.ros/log] is over 1GB.
It's recommended that you use the 'rosclean' command.

started roslaunch server http://10.1.1.236:45159/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /camera/driver/rgb_frame_id
 * /camera/driver/rgb_camera_info_url
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/driver/depth_frame_id
 * /camera/depth/rectify_depth/interpolation
 * /rosversion
 * /camera/driver/device_id
 * /camera/driver/depth_camera_info_url

NODES
  /camera/depth/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)
    disparity (nodelet/nodelet)
    points (nodelet/nodelet)
  /camera/rgb/
    rectify_mono (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
  /
    camera_nodelet_manager (nodelet/nodelet)
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
  /camera/
    driver (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)
    disparity (nodelet/nodelet)

ROS_MASTER_URI=http://10.1.1.236:11311

core service [/rosout] found
process[camera_nodelet_manager-1]: started with pid [3714]
process[camera/driver-2]: started with pid [3715]
process[camera/rgb/rectify_mono-3]: started with pid [3716]
process[camera/rgb/rectify_color-4]: started with pid [3717]
process[camera/ir/rectify_ir-5]: started with pid [3718]
process[camera/depth/rectify_depth-6]: started with pid [3719]
process[camera/depth/metric_rect-7]: started with pid [3720]
process[camera/depth/metric-8]: started with pid [3721]
process[camera/depth/disparity-9]: started with pid [3722]
process[camera/depth/points-10]: started with pid [3723]
process[camera/register_depth_rgb-11]: started with pid [3724]
process[camera/depth_registered/rectify_depth-12]: started with pid [3725]
process[camera/depth_registered/metric_rect-13]: started with pid [3726]
process[camera/depth_registered/metric-14]: started with pid [3727]
process[camera/depth_registered/disparity-15]: started with pid [3728]
process[camera/points_xyzrgb_depth_rgb-16]: started with pid [3729]
process[camera_base_link-17]: started with pid [3730]
process[camera_base_link1-18]: started with pid [3731]
process[camera_base_link2-19]: started with pid [3732]
process[camera_base_link3-20]: started with pid [3733]
[ WARN] [1320143490.801048791]: The input topic '/camera/ir/image_raw' is not yet advertised
[ WARN] [1320143490.801367560]: The input topic '/camera/ir/camera_info' is not yet advertised
[ WARN] [1320143491.073711844]: The input topic '/camera/rgb/image_color' is not yet advertised
[ WARN] [1320143491.073879695]: The input topic '/camera/rgb/camera_info' is not yet advertised
[ WARN] [1320143496.824584852]: The input topic '/camera/depth/image_raw' is not yet advertised
[ WARN] [1320143496.824778955]: The input topic '/camera/depth/camera_info' is not yet advertised
[ WARN] [1320143497.328093357]: The input topic '/camera/depth_registered/image_raw' is not yet advertised
[ WARN] [1320143497.328300018]: The input topic '/camera/depth_registered/camera_info' is not yet advertised
[ INFO] [1320143497.637915285]: No devices connected.... waiting for UINT8devices to be connected
[ WARN] [1320143499.605090904]: The input topic '/camera/rgb/image_mono' is not yet advertised
[ WARN] [1320143499.605297448]: The input topic '/camera/rgb/camera_info' is not yet advertised
[ WARN] [1320143499.610174617]: WallTimer destroyed immediately after creation.  Did you forget to store the handle?
[ INFO] [1320143500.648300238]: No devices connected.... waiting for devices to be connected
[ INFO] [1320143503.658278461]: No devices connected.... waiting for devices to be connected
[ INFO] [1320143506.668430974]: No devices connected.... waiting for devices to be connected
[ INFO] [1320143509.678573987]: No devices connected.... waiting for devices to be connected
[ INFO] [1320143512.688693807]: No devices connected.... waiting for devices to be connected

Originally posted by toniOliver on ROS Answers with karma: 159 on 2011-11-01

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try launching:

roslaunch openni_camera openni_node.launch

This works for me in diamondback. It seems that for electric your are launching the right one tough.


Originally posted by Enrique with karma: 834 on 2011-11-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.