0
$\begingroup$

Rosanswers logo

Hi! im using ROS Electric installed from sources and OpenCV from svn and its has version 2.3.2 but if im trying to make cv_bridge

rosmake cv_bridge

it want to use 2.3.1:

Package opencv-2.3.1 was not found in the pkg-config search path.

How could i use OpenCV 2.3.2 instead of 2.3.1? Thanks!


Originally posted by noonv on ROS Answers with karma: 471 on 2011-10-30

Post score: 1

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

One way that works for me consists in:

  1. Copying the ROS OpenCV package somewhere. You may renamed this new package to something like opencv232.
  2. Changing the Makefile so it downloads the last svn version.
  3. Then rosmake -i (remove ROS_NOBUILD fisrt).

For cv_bridge:

  1. Copy cv_bridge
  2. Rename (opcional)
  3. Change manifest dependency to opencv232
  4. rosmake -i

Maybe not so clean, but it works.


Originally posted by Enrique with karma: 834 on 2011-11-01

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by noonv on 2011-11-01:
Thanks a lot!

$\endgroup$
0
$\begingroup$

Rosanswers logo

this answer help me:

Sometimes the ROS package might be looking for a particular .pc filename, like "opencv-2.3.pc", when your build of opencv 2.3 only placed a "opencv.pc" file there. Then, my solution is to create a symbolic link, in this case from "opencv.pc" to "opencv-2.3.pc" in the relevant pkgconfig path.

my actions:

sudo cp /usr/local/lib/pkgconfig/opencv.pc /usr/local/lib/pkgconfig/opencv-2.3.1.pc

edit opencv-2.3.1.pc and change 2.3.2 on 2.3.1

check:

pkg-config opencv-2.3.1 --cflags
pkg-config opencv-2.3.1 --libs

and

rosmake cv_bridge

it make ok, but with warning:

[ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: opencv2.3 Consider using --rosdep-install option or rosdep install c v_bridge


Originally posted by noonv with karma: 471 on 2011-11-01

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.