0
$\begingroup$

Rosanswers logo

This question is a follow-on to the question previously answered in the thread Any microstrain imu driver supporting 3DM-GX3 protocol?.

I have a Microstrain 3DM-GX3-25 AHRS and I'm hoping to use it with ROS Diamondback on Natty. According to the closed thread, there is a patch under imu_drivers 1.2.4. I just added the stack using apt three days ago but I can't verify the release version. Looking at the stack, I can see the microstrain_3dmgx2_imu package. Is this supposed to work for the 3DM-GX3?


Originally posted by wkr101 on ROS Answers with karma: 63 on 2011-10-23

Post score: 0


Original comments

Comment by tfoote on 2011-10-23:
You can determine the version of a stack easily by using the rosversion tool, rosversion imu_drivers 1.2.4 is the version released into diamondback see http://www.ros.org/wiki/imu_drivers/Releases

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Okay, so I have it working so I guess that answers my question. I was able to use the microstrain_3dmgx2_imu package directly following the tutorial.

I did verify the stack version was 1.2.4 using rosversion (thanks tfoote).


Originally posted by wkr101 with karma: 63 on 2011-10-27

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.