0
$\begingroup$

Rosanswers logo

Hi,

We are trying to get the warehouse_viewer running, using two lwr robot arms. We're following the warehouse_viewer tutorial.

The robot planning description is made using the planning description config wizard, so launch files are created as described in 4.2.3 (using ./scripts/create_launch_files.py).

When launching planning_scene_warehouse_viewer_lbr.launch, the program gets stuck and the following lines get printed:

[ INFO] ik_utilities: waiting for IK services to be there
[ INFO] ik_utilities: waiting for IK services to be there
[ INFO] Environment server started
[ INFO] Successfully connected to planning scene action server for /planning_scene_validity_server
[ INFO] Successfully connected to planning scene action server for /ompl_planning
[ INFO] Successfully connected to planning scene action server for /lbr_lbr_2_kinematics
[ INFO] Successfully connected to planning scene action server for /lbr_lbr_1_kinematics
[ INFO] Successfully connected to planning scene action server for /trajectory_filter_server

Looks like some IK-services can't be found. When reading out the tf-topic, it seems like only tip and base links are being published.

Any ideas?

Regards,
Eli


Originally posted by erkmns on ROS Answers with karma: 91 on 2011-10-17

Post score: 0


Original comments

Comment by egiljones on 2011-10-17:
I think ik is actually starting up just fine - this actually looks like it should. What do you mean the program 'gets stuck'? You get to the screen where you have to hit "Accept" right? And then you never get to the point where you get the option to create a new planning scene? Make sure that the entries in planning_scene_warehouse_viewer_lbr.launch for left_interpolate_service_name and right_interpolate_service_name are set to 'none' - that might not work correctly for your robot.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Setting the entries in planning_scene_warehouse_viewer_lbr.launch for left_interpolate_service_name and right_interpolate_service_name to 'none' indeed solves the problem. Thanks a lot!


Originally posted by erkmns with karma: 91 on 2011-10-18

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.