0
$\begingroup$

Rosanswers logo

Hi,

I'm trying to install orocos_toolchain_ros on electric release following the instructions on your web page: sudo aptitude install ros-electric-orocos-toolchain ros-electric-rtt-ros-integration ros-electric-rtt-ros-comm ros-electric-rtt-common-msgs ros-electric-rtt-geometry

and the first error that I find is that the ros-electric -rtt-geometry package can't be found.

If I follow with the instructions avoiding this package, when I'm trying to do:

sudo git clone http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git

I get the following errors: error: inflate: data stream error (incorrect header check) error: File 318458b05854f9a89b044e010a1738351bd6244a (http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git/objects/a8/18ccadb911aa86a9120d25981d64abf102dd30) corrupt


Originally posted by MioRos on ROS Answers with karma: 26 on 2011-10-13

Post score: 0

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

Have you tried running "sudo apt-get update" first? The new rtt packages were only recently released and require an up-to-date apt index.


Originally posted by kwc with karma: 12244 on 2011-10-17

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by MioRos on 2011-10-27:
Ok.

After running "sudo apt-get update" first, the first error is solved but not the second one.

Any idea ...?

$\endgroup$
0
$\begingroup$

Rosanswers logo

After running "sudo apt-get update" first, I can successfully install the Ubuntu packages running " sudo aptitude install ros-electric-orocos-toolchain ros-electric-rtt-ros-integration ros-electric-rtt-ros-comm ros-electric-rtt-common-msgs ros-electric-rtt-geometry"

However, I still can't install orocos_toolchain_ros from source using "sudo git clone http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git"

Any idea ...?


Originally posted by MioRos with karma: 26 on 2011-10-20

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Steven Bellens on 2011-11-18:
Can you describe the problem in more detail? The 'data stream error' makes the git repository not check out correctly? Is it empty, or only partially there? Do you get any other error messages from git?

Comment by Wim on 2011-11-18:
I have the same problem when trying to install orocos_toolchain_ros from source. The best thing to do is to file a ticket on bugs.orocos.org.

$\endgroup$
0
$\begingroup$

Rosanswers logo

You can safely ignore this second error (inflate data stream), the GIT repository should be checkout out correctly anyway.


Originally posted by Steven Bellens with karma: 735 on 2011-11-03

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.