0
$\begingroup$

Rosanswers logo

Based on many questions ihere, it looks like there is a problem with the openni driver that makes it not publish reliably. I'm having this same problem.

I'm running ubuntu 11.04 and ros diamondback.

I've tried both installing the driver directly as well as building it from the source as described here: http://www.ros.org/wiki/openni_camera
I have ps-engine and openni-dev packages installed.

When launching: roslaunch openni_camera openni_node.launch

I get something that looks like this:...

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [17226]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to ad069ada-f504-11e0-b3d7-b05ba57903
process[rosout-1]: started with pid [17239]
started core service [/rosout]
process[openni_node1-2]: started with pid [17248]
process[kinect_base_link-3]: started with pid [17252]
process[kinect_base_link1-4]: started with pid [17253]
process[kinect_base_link2-5]: started with pid [17254]
process[kinect_base_link3-6]: started with pid [17260]
[ INFO] [1318446127.209918971]: [/openni_node1] Number devices connected: 1
[ INFO] [1318446127.210083741]: [/openni_node1] 1. device on bus 001:12 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'B00363247819047B'
[ INFO] [1318446127.211848426]: [/openni_node1] searching for device with index = 1
[ INFO] [1318446127.250457248]: [/openni_node1] Opened 'Xbox NUI Camera' on bus 1:12 with serial number 'B00363247819457B'
[ INFO] [1318446127.259633975]: rgb_frame_id = '/openni_rgb_optical_frame'
[ INFO] [1318446127.260773433]: depth_frame_id = '/openni_depth_optical_frame'

but the red laser never turns on (although the green LED continues to blink when it is plugged into one of my USB 2.0 ports).

Any ideas on what could be the problem? The strange thing is, I've viewed point clouds through rviz recently so I've had it working. I didn't think I've done anything to break it, but not sure what happened. I've seen some others talk about the driver only coming up 1/5 times or 1/10 times, but in my case it isn't coming up at all.

.... If I can get past these driver problems, I would have some interesting point cloud work to start doing!

thanks in advance for any advice,

Walt


Originally posted by walt on ROS Answers with karma: 16 on 2011-10-12

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The answer here worked for me:

http://answers.ros.org/question/1892/openni_kinect-installation-issues-with


Originally posted by walt with karma: 16 on 2011-10-12

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.