0
$\begingroup$

Rosanswers logo

Hey,

When I was trying to install the Openni for kinect, I ran into a build error

make[3]: * [../../Bin/Release/libXnDeviceSensorV2.so] Error 1 make[3]: Leaving directory /home/vin/drivers/ps_engine/build/ps_engine/Platform/Linux-x86/Build/XnDeviceSensorV2' make[2]: *** [XnDeviceSensorV2] Error 2 make[2]: Leaving directory/home/vin/drivers/ps_engine/build/ps_engine/Platform/Linux-x86/Build' make[1]: [installed] Error 2 make[1]: Leaving directory `/home/vin/drivers/ps_engine' make: ** [ps_engine_lib] Error 2

Could somebody help me with this? I've asked this before a couple of days back but received no reply!

Thanks a lot!


Originally posted by Vinayak on ROS Answers with karma: 21 on 2011-10-07

Post score: 0


Original comments

Comment by karthik on 2011-10-08:
Hi, pls mention how you are trying to install the openni and links that you followed. Also post the errors in code format, which makes it easy to analyse. The errors in the above case are incomplete, it just tells that the make has failed but not y. So pls post the line that describes the error.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Vinayak, I got this issue resolved when i removed

fix-mac-arch

(Just comment it #fix-mac-arch)

in the Makefiles of both openni and ps_engine in the drivers folder. It should work. This is the fix done for the Mac OS, so not used in Ubuntu version (Hoping you are working on ubuntu).

After this you might get an error in making nite. Where it might fail because of the proxy config in your wgetrc. Solution for that would be to set the proxy or to download the package mentioned in the nite's Makefile manually and compile it.

Hope this helps. Karthik


Originally posted by karthik with karma: 2831 on 2011-10-12

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.