0
$\begingroup$

Rosanswers logo

Hi, I previously posted an issue regarding errors in openni drivers installation (http://answers.ros.org/question/2297/openni-drivers-installation-errors). With the answer to this question i was able to install the drivers successfully. Then i ran the openni_camera node's openni_node.launch file, which says the devices is not connected.

aravindhan@rrc-laptop:~$ roslaunch openni_camera openni_node.launch
... logging to /home/aravindhan/.ros/log/a30405ca-f056-11e0-83fc-5c260a051546/roslaunch-rrc-laptop-22434.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://rrc-laptop:42441/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /openni_node1/use_indices
 * /openni_node1/depth_registration
 * /openni_node1/image_time_offset
 * /openni_node1/depth_frame_id
 * /openni_node1/depth_mode
 * /openni_node1/debayering
 * /rosversion
 * /openni_node1/projector_depth_baseline
 * /openni_node1/rgb_frame_id
 * /openni_node1/depth_rgb_translation
 * /openni_node1/depth_time_offset
 * /openni_node1/image_mode
 * /openni_node1/shift_offset
 * /openni_node1/device_id
 * /openni_node1/depth_rgb_rotation

NODES
  /
    openni_node1 (openni_camera/openni_node)
    kinect_base_link (tf/static_transform_publisher)
    kinect_base_link1 (tf/static_transform_publisher)
    kinect_base_link2 (tf/static_transform_publisher)
    kinect_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [22450]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to a30405ca-f056-11e0-83fc-5c260a051546
process[rosout-1]: started with pid [22463]
started core service [/rosout]
process[openni_node1-2]: started with pid [22473]
process[kinect_base_link-3]: started with pid [22476]
process[kinect_base_link1-4]: started with pid [22477]
process[kinect_base_link2-5]: started with pid [22478]
process[kinect_base_link3-6]: started with pid [22479]
[ INFO] [1317931571.886741090]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931572.887058521]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931573.887393253]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931574.887772578]: [/openni_node1] No devices connected.... waiting for devices to be connected
[ INFO] [1317931575.888150279]: [/openni_node1] No devices connected.... waiting for devices to be connected

What possibly could be wrong here?

Thanks in advance, Karthik


Originally posted by karthik on ROS Answers with karma: 2831 on 2011-10-06

Post score: 1


Original comments

Comment by fergs on 2011-10-06:
Please post the output of "lsusb"

$\endgroup$

4 Answers 4

0
$\begingroup$

Rosanswers logo

Reinstalled Ubuntu 11.04 (32bit) installed ROS electric and everything else. Now started getting the pointcloud from Kinect in rviz. Hope this is not the solution to the question but since I couldn't find much help on this, I had to go this way. So this is one of the solution to the problem.

Thanks Karthik


Originally posted by karthik with karma: 2831 on 2011-10-13

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Same problem here with ubuntu 10.04, it seems to be an issue with the libusb-1.0-0-dev or the openni-dev libraries...

The solution was to re-install the dependecies of the openni_kinect stack

First unistall the OpenNI developer package

$ sudo apt-get remove openni-dev libusb-1.0-0-dev

and reinstall it afterwards

$ sudo apt-get install openni-dev libusb-1.0-0-dev

Then recompile the package usign the --rosdep-install and --pre-clean options

$ rosmake openni_ros --rosdep-install --pre-clean

Let me know if it works for you...

regards..

Mario


Originally posted by Mario Garzon with karma: 802 on 2011-12-12

This answer was NOT ACCEPTED on the original site

Post score: 5


Original comments

Comment by karthik on 2011-12-14:
thanks mario; but i am not able to check it now as things are working fine for me after the new installation.

$\endgroup$
0
$\begingroup$

Rosanswers logo

I've had this problem before and solved it by killing the XnSensorServer.

killall XnSensorServer

Originally posted by Asomerville with karma: 2743 on 2011-12-13

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Adding my own notes from troubleshooting...

Sometimes it can also be a power problem. Check to make sure the connect turlebot adapter (or wall adapter) is plugged in and the green light on the connector is on. Verify the icreate base is on.

Try an lsusb. You should see 3 devices from "Microsoft Corp". If you only see one, the kinect may not have full power.


Originally posted by brianpen with karma: 183 on 2012-02-10

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.