0
$\begingroup$

Rosanswers logo

Hey,

i'm trying to install openNI electric package, but I getting this errors:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-electric-openni-kinect : Depends: ros-electric-common-msgs (= 1.6.0-s1313699542~lucid) but it is not going to be installed
                              Depends: ros-electric-driver-common (= 1.2.3-s1313700560~lucid) but it is not going to be installed
                              Depends: ros-electric-geometry (= 1.6.0-s1313700345~lucid) but it is not going to be installed
                              Depends: ros-electric-image-common (= 1.6.0-s1313700642~lucid) but it is not going to be installed
                              Depends: ros-electric-image-pipeline (= 1.6.1-s1314697348~lucid) but it is not going to be installed
                              Depends: ros-electric-nodelet-core (= 1.6.0-s1313699788~lucid) but it is not going to be installed
                              Depends: ros-electric-orocos-kinematics-dynamics (= 0.2.1-s1313700218~lucid) but it is not going to be installed
                              Depends: ros-electric-perception-pcl (= 1.0.1-s1315517480~lucid) but it is not going to be installed
                              Depends: ros-electric-ros (= 1.6.2-s1313697718~lucid) but it is not going to be installed
                              Depends: ros-electric-ros-comm (= 1.6.2-s1313697791~lucid) but it is not going to be installed
                              Depends: ros-electric-vision-opencv (= 1.6.1-s1313700748~lucid) but it is not going to be installed
E: Broken packages

Anyone know why?

Thank you.


Originally posted by gustavQ on ROS Answers with karma: 1 on 2011-10-04

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Sometimes the package repository gets into a confused state while being updated.

Usually, these problems go away if you try again later.


Originally posted by joq with karma: 25443 on 2011-10-04

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

Your Problem sounds quite similar to this one: unmet-dependency-problem-while-installing-electric

Did you manually install pcl and/or eigen? It may help if you try to install some of the needed packages alone to find the root cause of the problem as they may all depend on the same conflicting package.

For example try: apt-get install ros-electric-perception-pcl

If that fails with a similar error, you can check the next level by picking one of the missing dependencies of perception-pcl.


Originally posted by Ben_S with karma: 2510 on 2011-10-30

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.