Rosanswers logo

Hi everyone,

I am experiencing some issues whith the rosserial_arduino tutorial "hello world" example. I am working on a ASUS eee PC with the latest ubuntu version (11.04) and a ROS release I installed during july 2011.

After installing the rosserial stack as described in the tutorial (http://www.ros.org/wiki/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup), I was able to upload the "hello world" sketch into my arduino duemilanove.

Following the "hello world (example publisher)" page (http://www.ros.org/wiki/rosserial_arduino/Tutorials/Hello%20World), the issue appears in the terminal where I run the 'rosrun rosserial_python serial_node.py /dev/ttyUSB0' command :

me:$ rosrun rosserial_python serial_node.py /dev/ttyUSB0 [INFO] [WallTime:1315932634.660507] ROS Serial Python Node [INFO] [WallTime:1315932634.673866] Connected on /dev/ttyUSB0 at 57600 baud [ERROR] [WallTime:1315932664.690539] Lost sync with device, restarting... ... ...

Also as expected, when I try to listen to the topic with 'rostopic echo chatter', I have this warning message : WARNING: topic [/chatter] does not appear to be published yet

I was able to run a sketch with an IR sensor on the arduino in a standalone mode, so the communication between the computer and the arduino seems fine.

Did anyone already experience this 'sync' issue ? Is there any other way of checking the synchronisation between the arduino and ROS ?

Thanks a lot for anyhelp :) Dr. Frederic Villeneuve-Seguier

Originally posted by Dr Frederic Villeneuve_Seguie on ROS Answers with karma: 1 on 2011-09-13

Post score: 0

Original comments

Comment by Dr Frederic Villeneuve_Seguie on 2011-09-16:
Thanks a lot, following your advice I tried with an atmega 2560 I had and the sync problem disapeared right away.

Comment by adasta on 2011-09-14:
Does your arduino duemilanove have a atmega168 or atmega328? If it is a 168, it is probably running out of memory. If so, check out this answer: http://answers.ros.org/question/2120/problem-setting-up-rosserial_arduino


1 Answer 1


Rosanswers logo

It looks like it was an out of memory error from comments above.

Originally posted by tfoote with karma: 58457 on 2011-09-17

This answer was ACCEPTED on the original site

Post score: 1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.