0
$\begingroup$

Rosanswers logo

Hi,

I am trying to run the first electric arm navigation tutorial called 'Planning Description Configuration Wizard'. Once I launch the PR2 example I get the following error: [planning_description_configuration_wizard-4] process has died [pid 6087, exit code -11]. log files: /home/wouter/.ros/log/a6475bbe-d2f2-11e0-859e-002710aa9e70/planning_description_configuration_wizard-4*.log waiting...

Running roswtf in a separate terminal gives the following error:

ERROR The following packages have rpath issues in manifest.xml:
 * planning_environment: found flag "-Wl,-rpath,/opt/ros/electric/stacks/perception_pcl/pcl_ros/lib", but no matching "-L/opt/ros/electric/stacks/perception_pcl/pcl_ros/lib"
 * pcl: found flag "-Wl,-rpath,/opt/ros/electric/stacks/perception_pcl/pcl/lib64", but no matching "-L/opt/ros/electric/stacks/perception_pcl/pcl/lib64"
 * pcl_ros: found flag "-Wl,-rpath,/opt/ros/electric/stacks/perception_pcl/pcl_ros/lib", but no matching "-L/opt/ros/electric/stacks/perception_pcl/pcl_ros/lib"
 * robot_self_filter: found flag "-Wl,-rpath,/opt/ros/electric/stacks/perception_pcl/pcl/lib64", but no matching "-L/opt/ros/electric/stacks/perception_pcl/pcl/lib64"

As suggested in another question (http://answers.ros.org/question/1212/what-is-the-correct-usage-of-rpath-in-manifestxml) I already tried to remove the -L prefix in the manifest.xml files but that didn't work. Therefore I reinstalled the debian package to make sure that I have the original manifest.xml file.

My OS is Ubuntu 11.04 with ROS Electric installed. Furthermore I have installed the Debian package called 'ros-electric-arm-navigation'.

Does anyone know how I can get the tutorial to work?

Wouter


Originally posted by Wouter on ROS Answers with karma: 130 on 2011-08-29

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I rolled back my linux installation to 10.04 32 bit and this solved the issue. Apparently the package is neither running properly under 11.04 nor under 10.04 64bit.


Originally posted by Wouter with karma: 130 on 2011-09-03

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Lorenzo Riano on 2011-10-18:
So on mine. Maybe this is not the right answer and the whole question should be marked as unanswered.

Comment by arebgun on 2011-09-03:
It does run fine on my installation of Ubuntu 10.04 64-bit.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.