0
$\begingroup$

Rosanswers logo

Hi! I've been using turtlebot software and things are generally working well for me, but I get a recurring warning often when I am running programs. The warning is about a Walltimer that is destroyed immediately after creation. I have not seen this warning in the tutorials I have been reading. Also, I wonder why there is often a lot more text generated on my screen and the process seems to restart several times before working. The output is below:


turtlebot@turtlebot-laptop:~$ roslaunch turtlebot_bringup kinect.launch

... logging to /home/turtlebot/.ros/log/96cb21b2-ce78-11e0-89ae-485d607f80f5/roslaunch-turtlebot-laptop-616.log

Checking log directory for disk usage. This may take awhile.

Press Ctrl-C to interrupt

Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.11.59:46906/

SUMMARY

PARAMETERS

  • /kinect_laser/max_height

  • /openni_camera/depth_rgb_rotation

  • /rosdistro

  • /openni_camera/image_mode

  • /openni_camera/image_time_offset

  • /openni_camera/projector_depth_baseline

  • /kinect_laser_narrow/output_frame_id

  • /openni_camera/depth_mode

  • /kinect_laser_narrow/max_height

  • /openni_camera/depth_frame_id

  • /openni_camera/depth_time_offset

  • /kinect_laser/output_frame_id

  • /rosversion

  • /openni_camera/depth_registration

  • /openni_camera/debayering

  • /openni_camera/depth_rgb_translation

  • /kinect_laser/min_height

  • /pointcloud_throttle/max_rate

  • /openni_camera/shift_offset

  • /kinect_laser_narrow/min_height

  • /openni_camera/rgb_frame_id

NODES /

kinect_breaker_enabler (turtlebot_node/kinect_breaker_enabler.py)

openni_manager (nodelet/nodelet)

openni_camera (nodelet/nodelet)

pointcloud_throttle (nodelet/nodelet)

kinect_laser (nodelet/nodelet)

kinect_laser_narrow (nodelet/nodelet)

ROS_MASTER_URI=http://192.168.11.59:11311

core service [/rosout] found

process[kinect_breaker_enabler-1]: started with pid [634]

process[openni_manager-2]: started with pid [635]

process[openni_camera-3]: started with pid [637]

process[pointcloud_throttle-4]: started with pid [638]

process[kinect_laser-5]: started with pid [639]

process[kinect_laser_narrow-6]: started with pid [649]

[ INFO] [1314208002.715270161]: [/openni_camera] No devices connected.... waiting for devices to be connected

[ INFO] [1314208003.725225403]: [/openni_camera] No devices connected.... waiting for devices to be connected

[kinect_breaker_enabler-1] process has finished cleanly.

log file: /home/turtlebot/.ros/log/96cb21b2-ce78-11e0-89ae-485d607f80f5/kinect_breaker_enabler-1*.log

[ INFO] [1314208004.733988250]: [/openni_camera] No devices connected.... waiting for devices to be connected

[ INFO] [1314208005.743716313]: [/openni_camera] No devices connected.... waiting for devices to be connected

[ INFO] [1314208006.753464806]: [/openni_camera] No devices connected.... waiting for devices to be connected

[ INFO] [1314208009.516836935]: [/openni_camera] Number devices connected: 1

[ INFO] [1314208009.517313312]: [/openni_camera] 1. device on bus 001:13 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'REMOVED BY POSTER'

[ WARN] [1314208009.520783850]: [/openni_camera] device_id is not set! Using first device.

[ INFO] [1314208009.580510752]: [/openni_camera] Opened 'Xbox NUI Camera' on bus 1:13 with serial number 'REMOVED BY POSTER'

[ INFO] [1314208009.626772874]: rgb_frame_id = 'kinect_rgb_optical_frame'

[ INFO] [1314208009.633046937]: depth_frame_id = 'kinect_depth_optical_frame'

[ WARN] [1314208010.582937446]: WallTimer destroyed immediately after creation. Did you forget to store the handle?

[ WARN] [1314208010.583345638]: WallTimer destroyed immediately after creation. Did you forget to store the handle?

[ WARN] [1314208010.583702928]: WallTimer destroyed immediately after creation. Did you forget to store the handle?

[ WARN] [1314208010.584037244]: WallTimer destroyed immediately after creation. Did you forget to store the handle?

[ WARN] [1314208010.584311458]: WallTimer destroyed immediately after creation. Did you forget to store the handle?


Originally posted by Aroarus on ROS Answers with karma: 122 on 2011-08-24

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I get the Walltimer message too, it seems to be a known issue. AFAICT it's benign, and probably not related to the other issues you're having (which from your description are not very clear -- I think you need to elaborate more on the restarting).


Originally posted by Patrick Bouffard with karma: 2264 on 2011-08-24

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.