0
$\begingroup$

Rosanswers logo

One of my robot parts is not displayed correctly in rviz. There is a gap in the model that should not be there.

I am using dae models to get texturing. The corresponding STL model is displayed correctly in rviz. The .dae has a gap. Also the .dae and .stl both show up correctly in meshlab.

gap in model

I have used blender to save the .dae model from the imported .stl and also tried meshlab. Both result in a gap in rviz.

I have used the same procedure for all other links of the robotmodel and they worked fine. Does anyone have an idea what could be the reason why this part doesn't work?


Originally posted by dornhege on ROS Answers with karma: 31395 on 2011-08-21

Post score: 0


Original comments

Comment by Pi Robot on 2011-08-22:
This doesn't help you but I have exactly the opposite problem--I have an STL model for an AX-12 Dynamixel servo that is invisible in RViz (Electric RC-1) but when I convert it to .dae using Blender, I can see it.

Comment by dornhege on 2011-08-22:
Yes. It's not the problem. I flipped all normals in meshlab and could see the backsides of the rest of the part. The gap was still invisible.

Comment by Stefan Kohlbrecher on 2011-08-22:
Have you checked the normals for the relevant part? I had a similar issue because of flipped normals in another model. OTOH, if all normals are flipped, we should be able to see the backside in the image.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It is more a fix than a solution, but I simplified the geometry of the part in a CAD program and could get it to show correctly in rviz. The geometry was quite detailed for the visual model, so I suspect rviz had problems displaying that.


Originally posted by dornhege with karma: 31395 on 2011-09-01

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.