0
$\begingroup$

Rosanswers logo

Hello everybody! My OS: Ubuntu 10.04

My TF configure: /map -> /odom -> /base_link -> /base_scan. image description

While the TF seems not problem, there is still an fatal error at RVIZ. RVIZ show an error about laser scan: unknown reason for transform failure. I'm confuse, so I need your help. I'm appreciate for any hints.

image description


Originally posted by gong on ROS Answers with karma: 164 on 2011-06-16

Post score: 6

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

How are you publishing the /scan topic?

It has to have the frame_id /base_scan set. Also it should have a current timestamp (i.e. corresponding to those in the rviz machine), this might be a problem with multiple computers.

Do you see a scan, if you set the fixed_frame in rviz to the frame_id of the scan?


Originally posted by dornhege with karma: 31395 on 2011-06-16

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by gong on 2011-06-16:
In my scan topic, I provide frame_id of scan to be "base_scan". Also, I'm setting the header.stamp of scan message to be current time as timestamp.

Comment by gong on 2011-06-16:
when I set /base_scan to be fixed frame in RVIZ, the fatal error is gone.

$\endgroup$
0
$\begingroup$

Rosanswers logo

I had the same problem; no laser data is shown in rviz unless the laser's frame is set as the fixed frame.

I found a thread on the ros-users list that suggested it had to do with the time_increment field being too large. I noticed there is an error in the LMS1xx package I'm using as a driver for the laser. The fields time_increment and scan_time are ten times as high as they are supposed to be.

I think this was the cause of the error message. What's annoying is that it took 20-30 minutes after I fixed this for it to actually start working. I don't know why it didn't start working immediately. It's possible I restarted rviz at that stage, or managed to reset its laser module. I sure didn't change anything else, at least.

Here's the list thread I mentioned: http://comments.gmane.org/gmane.science.robotics.ros.user/5192


Originally posted by raahlb with karma: 317 on 2011-09-20

This answer was NOT ACCEPTED on the original site

Post score: 3


Original comments

Comment by Markus Bader on 2014-07-22:
Setting the time_increment to zero solved my problem.

Comment by AlexM on 2019-07-08:
For other people trying to make YDLIDAR work -- there's a bug in their ROS package which results in the same issue, and an open PR for it -- https://github.com/EAIBOT/ydlidar/pull/19/files.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.