0
$\begingroup$

Rosanswers logo

I'm trying to set up turtlebot but I'm using a bumblebee camera instead of a kinect. I was wondering if anyone has done this before and how to go about doing it.

So far what I have done is commenting out the kinect node in robot.launch and adding a bumblebee node in there which looks like this

  <!-- Bumblebee2 -->
  <node pkg="bumblebee2" type="bumblebee2" name="bumblebee2"
    output="screen" respawn="true">
    <param name="video_mode" value="FORMAT7_3" />
    <param name="fps" value="15" />
    <param name="gain" value="auto" />  
    <param name="brightness" value="auto" />
    <param name="whitebalance" value="auto" /> 
    <param name="shutter" value="auto" />   
    <param name="bayer_pattern" value="BGGR" /> 
    <param name="bayer_method" value="NONE" /> 
  </node>
  <env name="ROS_NAMESPACE" value="bumblebee2" />
  <node pkg="stereo_image_proc" type="stereo_image_proc" name="stereo_image_proc" /> 

When I start turtlebot, I will get a Bad Gyro Callibration under Sensors Error in Diagnostics from the turtlebot dashboard. Another anomaly I observed is that [kinect_breaker_enabler-8] process has finished cleanly in the terminal where I'm running robot.launch (Well, I did comment out the entire kinect node so this might happen but would this lead to any problems? and how do you solve it?) Logfile attached:kinect_breaker_enabler-8.log.jpg(change .jpg to .log after download, they won't let me upload log files)

I'm still quite new to this and I do not understand how openni is used in turtlebot(it seems to appear several times in the launch file, so I'm not sure if changing the camera would require me to reconfigure some things in openni)

I would be really grateful to anyone who could help me with this.


Originally posted by ccm on ROS Answers with karma: 226 on 2011-06-15

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

To get rid of the bad gyro calibration error you need to see the has_gyro param to False since you do not have a gyro. If you would like to add a gyro you can follow the directions here: http://answers.ros.org/question/717/is-an-imu-required-to-run-turtlebot-stack.

The kinect_breaker_enable is a boot strapping thing we did to turn on the breaker to power the kinect. you can remove it from the base.launch file. But it shouldn't effect anything you're doing all it does is come up and request the breaker to turn on and then exits.

On a side note, you should be aware that if you do not get good depth information from the bumblebee2 you may not be able to navigate well. Also not having a gyro will greatly diminish your ability to navigate.


Originally posted by mmwise with karma: 8372 on 2011-06-15

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by mmwise on 2011-06-16:
edit the driver.launch 4 5 6

Comment by ccm on 2011-06-16:
Thanks a lot. By the way, do you know how to set the has_gyro param? I can't seem to find a file with gyro in it. >.<

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.