0
$\begingroup$

Rosanswers logo

Hi everyone,

I'm trying to set up Eclipse to use as IDE for my ROS packages. I decided to go with Eclipse above any other IDE because it's listed first in the ROSwiki. http://www.ros.org/wiki/IDEs I tried to follow steps 1-4 so far. I'm afraid a few things went wrong tough:

PROBLEM 1: ROSwiki Instructions step 4: Properties --> C/C++ Make Project --> Environment, and check whether the following environment variables are assigned to the correct values:

ROS_ROOT

ROS_PACKAGE_PATH

PYTHONPATH

PATH

My issue: These variables were added, also in my case, but I dont understand their assign value: for e.g. path the value the value is set to /opt/ros/diamondback/ros/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games which is also what i get if using "echo $PATH" ... is this correct? is this valid path? why to "mulitple" locations

PROBLEM 2: If I have a look at the binaries in my packate (I use the "beginners_tutorial" package as described on the ROSwiki) there is the "listener" and "talker" but they contain garbage like ELF �U RHCF�* ���&�DMh( )�

now if i expand the "talker" i also do find the "correct" code in a cpp file. But it seems something went wrong anyway if I have somethink like to above, no?

PROBLEM 3: under "Problems" I get one warning Description Resource Path Location Type Invalid project path: Include path not found (/opt/ros/diamondback/ros/core/roslib/msg_gen/cpp/include). beginner_tutorials-RelWithDebInfo@beginner_tutorials pathentry Path Entry Problem

PROBLEM 4: I just cannot build the project, the build button is greyed out.

Really glad for any help with my problems. Many thanks in advance.


Originally posted by tschoni on ROS Answers with karma: 18 on 2011-05-29

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Problem 1 is not a problem, it is normal. The path variable applies to all applications not just ROS so it points to the typical Linux directories.

Problem 2 doesn't seem like a problem either. Binary files are executable machine code. You aren't expected to look at them with a text editor. You would need a debugger or disassembler to make any sense of them.

3 - I assume the "Problems" heading you mention is actually "Console" window? Make sure the missing path actually exists then Go to Project/Properties and add the missing include path. It should have been included when you imported the project after doing the make project-eclipse, if your original version of the talker/listener was successfully compiling/running from the command line development steps in the tutorial.

Problem 4 is simple when you know how (but not when you don't). If the file has not been edited since the last successful compile, the Project/Build Project option is greyed out. Go to the source file, enter a single space somewhere and try again.


Originally posted by Bart with karma: 856 on 2011-05-29

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Bart on 2011-05-31:
Thanks Gunther. "Problems" is a window I have never used. I will give it a try.

Comment by tschoni on 2011-05-29:
very very absolutely happy, first I was skeptical that so many "problems" show up, but turns out none of them very real ones :) it all works perfectly fine, thanks for the advice

Comment by Martin Günther on 2011-05-29:
Re problem #3: That warning can safely be ignored. (@Bart: it is actually the "Problems" view, not the "Console" view.) It stems from roslib incorrectly exporting msg_gen/cpp/include in its manifest.xml, but that dir doesn't exist. If you like, you can delete the path from Project/Properties.

Comment by Bart on 2011-05-29:
p.s. - don't forget step 5 of the tutorial or your application won't run properly and start roscore first. I recommend getting familiar with the text editor/rosmake process as described in the simple tutorials first before trying Eclipse. Learn about the manfest.xml and CMakeLists.txt files first.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.