0
$\begingroup$

Rosanswers logo

Hi All,

I am using Ubuntu 10.10 and try to install ROS. I followed every step found on the website, but something is wrong at the last step. Any suggestions or hints would be appreciated.The output is as follows. (The Linux kernel is 2.6.37, and before I tried to install ROS, I had installed Matlab R2010b -- not sure if this is related, just FYI)

$ sudo apt-get install ros-diamondback-desktop-full

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-diamondback-desktop-full : Depends: ros-diamondback-ros-tutorials (= 0.2.4-s1299046906~maverick) but it is not going to be installed

Depends: ros-diamondback-geometry-tutorials (= 0.1.3-s1299047065~maverick) but it is not going to be installed

Depends: ros-diamondback-slam-gmapping (= 1.2.2-s1301689879~maverick) but it is not going to be installed

Depends: ros-diamondback-ros (= 1.4.6-s1298587606~maverick) but it is not going to be installed


Originally posted by DG on ROS Answers with karma: 31 on 2011-05-18

Post score: 3


Original comments

Comment by DG on 2011-05-18:
Just updated. Thanks for reminding, Asomerville. First time here.

Comment by Asomerville on 2011-05-18:
Could you update the title of your post to more specifically state your issue; something like "Dependency install failure: ros-diamondback-ros-tutorials"

Comment by DG on 2011-05-18:
Yes, I ran it.

Comment by Eric Perko on 2011-05-18:
Did you run 'sudo apt-get update' before 'sudo apt-get install...'?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I got similar errors when I accidentally added the wrong package source. E.g., I added the source for Maverick even though I was running Lucid.

Double check which version of Ubuntu you are running using

cat /etc/issue

and the package source you added using

 cat /etc/apt/sources.list.d/ros-latest.list

Originally posted by sebsch with karma: 790 on 2011-05-25

This answer was ACCEPTED on the original site

Post score: 2

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.