0
$\begingroup$

Rosanswers logo

I am having trouble launching OpenNI in ROS. Here is the code that is generated in the terminal. Please help!

...auto-starting new master

process[master]: started with pid [2865]

ROS_MASTER_URI=http://localhost:11311

setting /run_id to b94a6992-7a85-11e0-9542-d48564bff373

process[rosout-1]: started with pid [2878]

started core service [/rosout]

process[openni_node1-2]: started with pid [2886]

process[kinect_base_link-3]: started with pid [2890]

process[kinect_base_link1-4]: started with pid [2892]

process[kinect_base_link2-5]: started with pid [2893]

process[kinect_base_link3-6]: started with pid [2894]

[ INFO] [1304977559.799925062]: [/openni_node1] Number devices connected: 1

[ INFO] [1304977559.800176015]: [/openni_node1] 1. device on bus 001:07 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'B00365709867102B'

[ INFO] [1304977559.802737337]: [/openni_node1] searching for device with index = 1

[ INFO] [1304977559.848618180]: [/openni_node1] Opened 'Xbox NUI Camera' on bus 1:7 with serial number 'B00365709867102B'

[ INFO] [1304977559.863246868]: rgb_frame_id = '/openni_rgb_optical_frame' 

[ INFO] [1304977559.865246392]: depth_frame_id = '/openni_depth_optical_frame'

Originally posted by eabryan on ROS Answers with karma: 1 on 2011-05-09

Post score: -2


Original comments

Comment by eabryan on 2011-05-09:
Also, I can not post the output from rostopic hz /camera/rgb/points because when I enter that command, the terminal does not respond.

Comment by eabryan on 2011-05-09:
The problem is: The terminal stops after those two lines. Shouldn't I be able to enter additional commands? The terminal window behaves as if it's still working on some part of the program.

Comment by Eric Perko on 2011-05-09:
What exactly is the problem you are having? That looks like normal startup for the openni_node. Can you post the output of 'rostopic hz /camera/rgb/points'? That will tell you if the driver is actually streaming data that you could then examine in rviz.

Comment by eabryan on 2011-05-09:
... the last two lines are: [ INFO] [1304977559.863246868]: rgb_frame_id = '/openni_rgb_optical_frame' [ INFO] [1304977559.865246392]: depth_frame_id = '/openni_depth_optical_frame'

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is entirely normal behavior. After successfully launching, the terminal will not allow you enter additional commands, as the driver is still working - it is in fact in the actual data streaming loop.

In order to run additional commands (such as rostopic hz /camera/rgb/points or rosrun rviz rviz), you will have to open new terminal windows to enter them in.

If you are new to ROS, I suggest you go through the beginner tutorials to get a feel for how you normally start, interact with and write ROS nodes.


Originally posted by Eric Perko with karma: 8406 on 2011-05-09

This answer was ACCEPTED on the original site

Post score: 4

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.