0
$\begingroup$

Rosanswers logo

I try to plot in 3D using "rxplot -M 3d". Here are the steps I do:

roscore
rosrun turtlesim turtlesim_node
rosrun turtlesim turtle_teleop_key
rxplot -M 3d /turtle1/pose/x /turtle1/pose/y

rxplot gives the following error:

rxplot: error: You may only specific 2 or 3 topics with '3d' or 'scatter'. When 2 topics are provided, time is used as the third axis.

These commands lead to the same error:

rxplot -M 3d /turtle1/pose/x:y
rxplot -M 3d /turtle1/pose/x,/turtle1/pose/y

Using three topics doesn't work either.

Using rxplot with option "-M 2d" works fine.

Can anyone give me a working example of how to plot in 3D?


Originally posted by Stephan on ROS Answers with karma: 1924 on 2011-04-27

Post score: 6

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

There's an open bug on this that I need to resolve first:

https://code.ros.org/trac/ros/ticket/3376


Originally posted by kwc with karma: 12244 on 2011-04-28

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Stephan on 2012-05-21:
For the record: This bug has been fixed long time ago and my turtlesim example from the question works now.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.