0
$\begingroup$

Rosanswers logo

I've successfully installed the packages, but when I try executing it, my computer lags/freezes when trying to run the code. The computer I've ran it on has a 2.4ghz dual core processor and 2gb of memory.

For those who have had success running the tool smoothly, what were the specs of the computer that you ran it on? Specifically the amount of memory and CPU speed?


Originally posted by Shark on ROS Answers with karma: 241 on 2011-03-09

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

2 GB is a bit short, I guess. 10 minutes sounds extreme though. There's a debug message (actually a WARN-level message) in the publish-method, so before sending the whole model, start up rxconsole and check whether you get messages like "Sending out a cloud with id X on topic XXX" during sending of the model. Do you get these?

Memory-wise, the best you can do is to restart rviz before sending the whole model, so the memory assigned to the individually sent point clouds is definitely freed. You could also try to record the whole with "rosbag record /rgbdslam/batch_clouds /tf", so you need no rviz in memory, and when you play it back later on you don't need rgbdslam to be running.

I will soon (April?) release an improved version that, among other improvements, uses less memory.


Originally posted by Felix Endres with karma: 6468 on 2011-03-12

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.