0
$\begingroup$

Rosanswers logo

Hello, My node is listening to 2 kinects on 8 topics for messages. Even though messages are published on all topics only 4 of the callbacks are invoked. I tried changing the LOOP_RATE, increased the QUEUE size but doesn't make a difference. Is there something I am doing wrong or missing? Here's the code that I was running: listener.cpp And here are my launch files for kinects: Kinect1_openni_node.launch, Kinect2_openni_node.launch, kinect_frames1.launch , kinect_frames2.launch Here's my rxgraph image description When I run listener.cpp , all I get is the following i.e. it skips messages from 4 topics

[ INFO] [1299768991.573907570]: Depth Image: [2]
[ INFO] [1299768991.580039704]: Kinect1 Depth Image: [6]
[ INFO] [1299768991.594992942]: Depth Points: [216]
[ INFO] [1299768991.598203115]: Depth Image: [2]
[ INFO] [1299768991.618901837]: Kinect1 Depth Points: [5]
[ INFO] [1299768991.622189841]: Kinect1 Depth Image: [6]
[ INFO] [1299768991.641956580]: Depth Points: [217]
[ INFO] [1299768991.646081980]: Depth Image: [2]
^C[ INFO] [1299768991.660327453]: Kinect1 Depth Points: [5]

Thanks for any help. Best, CV


Originally posted by blueskin on ROS Answers with karma: 284 on 2011-03-09

Post score: 1


Original comments

Comment by blueskin on 2011-03-10:
@Tully & @ Felix Endres: I've updated my question as requested. Please let me know your opinion. Thank you.

Comment by Felix Endres on 2011-03-09:
It's impossible to say, unless you at least tell us which topics you subscribed to.

Comment by Tully on 2011-03-09:
Please add more information to help us debug. Such as sample code, launch files, outputs of rxgraph, and appropriate rostopic hz. This sounds like a configuration issue not a code issue.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Depending on what settings you have configured the Kinect with it does not necessarily publish on all advertised topics. Some are mutually exclusive.

I recommend that you look at what settings you have configured using rosrun dynamic_reconfigure reconfigure_gui and the documentation in openni_camera


Originally posted by tfoote with karma: 58457 on 2011-03-10

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Felix Endres on 2011-03-12:
While this is true, i think these topics are not the mono/rgb image and the clouds. I have no better idea though.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.