0
$\begingroup$

Rosanswers logo

I've been following along with the wiki: http://www.ros.org/wiki/ni

I've got diamondback, and my libusb is 1.0.8:

$ aptitude show libusb-1.0-0-dev
Package: libusb-1.0-0-dev                
State: installed
Version: 2:1.0.8-2

When I do "rosmake ni --rosdep-install" I get these errors:

Failed to find rosdep libusb1.0 for package ps_engine on OS:ubuntu version:10.10
Failed to find rosdep libusb1.0 for package openni_camera on OS:ubuntu version:10.10
Failed to find rosdep libusb1.0 for package openni_tracker on OS:ubuntu version:10.10
Failed to find rosdep libusb1.0 for package openni on OS:ubuntu version:10.10
Failed to find rosdep libusb1.0 for package nite on OS:ubuntu version:10.10
Failed to find rosdep libusb1.0 for package openni_pcl on OS:ubuntu version:10.10
WARNING: Rosdeps [u'libusb1.0', u'libusb1.0', u'libusb1.0', u'libusb1.0', u'libusb1.0', u'libusb1.0'] could not be resolved

And then it dies on:

Linking CXX executable ../bin/openni_viewer
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_close'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_find_devices'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_open'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_find_busses'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_get_string_simple'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_init'
  /home/murph/src/robos/ros-workspace/ni/openni_camera/lib/libopenni_driver.so: undefined reference to `usb_busses'
  collect2: ld returned 1 exit status

Any clue what I missed?


Originally posted by Murph on ROS Answers with karma: 1033 on 2011-02-24

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

There was a missing export of -lusb in the openni_camera. I've patched it in the master branch of ni.

commit f79573351876695203dae7a9680cf8449a5ab17b Author: Tully Foote [email protected] Date: Thu Feb 24 11:25:08 2011 -0800

missing export

Originally posted by tfoote with karma: 58457 on 2011-02-24

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.