0
$\begingroup$

Gazebo Answers logo

Hello,

i am currently trying to build a simple car model from scratch. So far my URDF comes along pretty good and my ROS Node also publishes data to the correct ros Node.

Lately i have tried to swich from all EffortJointInterface/PositionJointCtrlr EffortJointCtrlr to:

2x VelocityJointInterface/VelocityJointCtrlr for the "Engine" of my wheels and 2x PositionJointInterface/PositionJointCtrlr for the Steering of my wheels.

But now i am only able to ctrl the position of my front wheels which are meant for steering and don't get any Velocity to my Rear Axle for forward motion.

!All ctrlr are in a running state, which makes it even stranger!

Do i need to lood the Hardware Interfaces separetly? Does anybody have experiece when working with different Ctrlr and Interfaces on the same model? I possible i want to avoid implementing my own interfaces.

Help is very much appreciated! Franzisdrak


Originally posted by Franzisdrak on Gazebo Answers with karma: 43 on 2016-09-17

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

Fixed the error. I forgot to change the Interfaces in my urdf.


Originally posted by Franzisdrak with karma: 43 on 2016-09-19

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Coach Allen on 2020-01-28:
What would be nice, is to see the actual code. Us new guys finding you had the same problem, and not seeing how you fixed doesn't do much.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.