0
$\begingroup$

I am trying to test a sensor circuit I'm working on. Essentially, I am using RealTerm to send commands to the microcontroller and it is returning the value read by the sensor.

When logging to a file in RealTerm, I noticed the commands being sent were showing up as well as the data being returned. I was wondering if anyone knew a way to record only the incoming data using RealTerm, and not the outgoing commands. Any suggestions would be greatly appreciated. Unfortunately, there is no way around using RealTerm specifically because of a company policy.

$\endgroup$
  • 1
    $\begingroup$ Also asked and answered here: electronics.stackexchange.com/questions/106073/… $\endgroup$ – Tut Apr 10 '14 at 15:54
  • $\begingroup$ @user40171 It is generally frowned upon to post the exact same question on two stack exchange sites, especially if you're not linking the questions to each other. $\endgroup$ – ThomasH Apr 30 '14 at 17:33
1
$\begingroup$

It sounds like RealTerm has local echo turned on. Apparently that setting in RealTerm is (incorrectly) called "half-duplex", and should be disabled for your purposes.

$\endgroup$
  • $\begingroup$ I played around with it a little, and Half duplex seems like it only applies to the display, but not the file being dumped to. I can't seem to find anything to turn off local echo in the file. Very strange $\endgroup$ – user40171 Apr 10 '14 at 14:58
  • $\begingroup$ It sounds like RealTerm just doesn't understand sourceforge.net/p/realterm/feature-requests/6 $\endgroup$ – Ian Apr 10 '14 at 15:29
0
$\begingroup$

You can use Cutecom on linux or Terminal on windows. Both of them log only incoming data.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.