2
$\begingroup$

I have created robot using a robot chassis kit from hobbyking. At first when testing the robot connected to USB power source and the wheels lifted above the ground everything seemed to be OK. Then, when I tried to power the robot with batteries I encountered a problem with starting the movement.

The robot hardly starts to move even when I power it with 100% of power - sometimes I have to push it a little bit in order to start driving.

As a newbie I don't know whether it is a power source (battery) or motors problem.

  • There are 4 motors with torque of 800gf.cm min in the chassis.
  • The gear ratio is 48:1 and to power the motors
  • I used two serially connected Li-ion batteries and dc-dc regulator which limits the voltage output to 5V.
  • The power is regulated with dual H-bridge motor driver.

According to specifications, the maximum free running current for a single motor is 250mA and I have read that the stall current is 3-8x running current.

Anyway, the problem is that the robot has problems with starting-up driving and I don't know how whether the motors are even powerful enough to move the robot or it is a power source problem or perhaps the obstacle could be solved with appropriate power regulation (ramp).

How can I solve this problem?

enter image description here

$\endgroup$
  • $\begingroup$ What is the current rating of your dc-dc regulator? $\endgroup$ – Mhz4.77 Apr 7 '14 at 17:45
  • $\begingroup$ What happens if you hold it in the air? Does everything appear to start smoothly? Put a voltmeter on the motor terminals (I'm assuming they are brushed motors), what voltage do you measure? $\endgroup$ – Guy Sirton Apr 8 '14 at 5:50
  • $\begingroup$ the batteries are not powerful enough. $\endgroup$ – NKN Apr 25 '14 at 15:01
1
$\begingroup$

Try running the motors in free-load condition (holding in air). If motor runs then, most likely they are not able to carry the load or the battery is dying. Try replacing the battery & see if that works well. Here in all, I am assuming that you boards are working well & enough power is reaching the output pins of the board (or input of motor).

Anyways, its difficult to run metal geared motors at 5V. What are the motor specifications?

Just to test, see if you can disconnect any 2 motors (either front or back) & see if the bot moves. This may give you some hints.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.