0
$\begingroup$

Gazebo Answers logo

I have a robot model (wam), launch file, and world file. When I run Gazebo by itself, I see the robot model show up in the "insert" menu and I can drop it in without problem. However, when I try to roslaunch my launch file, I get Error [parser.cc:528] Unable to find uri[model://wam_description] . Not only that, but all of a sudden I can no longer see the robot in the "insert" menu (I can't see any of my robots. Only the .gazebo folder and the online database).

Any advice on how to get this roslaunch working?

I'm using Gazebo 4 and am running ROS Indigo.

I have a catkin workspace in ~/path/ros_stuff.

In ros_stuff, I have a number of gazebo model directories, but the relevant ones are: wam_gazebo and wam_description.

Within wam_gazebo I have:

launch/
  wam.launch
worlds/
  wam.world
CMakeLists.txt
package.xml

Within wam_description I have:

meshes/
  ... a bunch of stl files.
CMakeLists.txt
package.xml
model.config
wam.sdf

in my .bashrc:

export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:~/path/ros_stuff/src/
source /opt/ros/indigo/setup.bash
source ~/path/ros_stuff/devel/setup.bash

Edit: I can succesfully roslaunch gazebo_ros empty_world.launch but my model directory (ros_stuff) still doesn't show up in the "insert" menu.

Bug confirmed. Workaround: Others have no confirmed this bug in the ticket that Jose posted. As a workaround until it's fixed, one can copy their models to the ~/.gazebo folder and they'll show up even when roslaunch is used.


Originally posted by Ben B on Gazebo Answers with karma: 175 on 2015-02-04

Post score: 0


Original comments

Comment by scpeters on 2015-02-04:
Does roslaunch preserve environment variables?

Comment by Ben B on 2015-02-05:
See my comment on Nate's comment. It doesn't seem to actually change the value in the environment.

Comment by scpeters on 2015-02-05:
Maybe the answers.ros.org folks would have some betting insight into this? Have you posted this there as well?

Comment by William on 2015-02-11:
Can you post the contents of your launch file, or at least the part of the launch file which launches gazebo?

Comment by Ben B on 2015-02-13:
William, this happens even when I roslaunch the standard empty_world.

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

I was able to reproduce the issue. It is not present if you don't use the roslaunch command.

I've created an issue to track it down and fix our current tutorial.

Thanks Ben for reporting.

Update 25/03/2015: this has been fixed and released for gazebo 4.1.2 and 5.1.0


Originally posted by Jose Luis Rivero with karma: 1485 on 2015-02-10

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by scpeters on 2015-02-16:
There is a fix in https://bitbucket.org/osrf/gazebo/pull-request/1430/preserve-previous-gazebo_model_path-values/diff

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.