0
$\begingroup$

Gazebo Answers logo

>     [MYROBOT.launch] is neither a launch file in package
> [MYROBOT_gazebo] nor is [MYROBOT_gazebo] a launch file name
  • my distribution is Hydro
  • I use ubuntu 12.10

any help,please

Thanks in advance


Originally posted by Eman on Gazebo Answers with karma: 3 on 2014-02-17

Post score: 0


Original comments

Comment by Ben B on 2014-02-17:
Have you run catkin_make in that workspace before launching?

$\endgroup$

2 Answers 2

0
$\begingroup$

Gazebo Answers logo

This indicates some kind of problem with your workspace setup. Either your "MYROBOT_gazebo" package could not be found, or your "MYROBOT_gazebo" package could be found, but not the "MYROBOT.launch" launch file inside it. To find out what is happening, you can try

roscd MYROBOT_gazebo

If get a "no such package/stack" error, the package could not be found.


Originally posted by Stefan Kohlbrecher with karma: 473 on 2014-02-18

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Eman on 2014-02-18:
@Stefan Kohlbrecher Thanks very much for your help. God bless you. I tried the command " roscd MYROBOT_gazebo " & I found the error that you mentioned ( roscd: No such package/stack 'MYROBOT_gazebo' ) . what should I do if the package are not found? Should I remove the catkin_WS & then recreate it & recreate the package?

Comment by Stefan Kohlbrecher on 2014-02-18:
This means you either made a mistake when following the tutorial, or there is an error in the tutorial. I´d suggest re-doing the tutorial and taking extra care not to miss anything. Hopefully that solves the problem, otherwise report back. Note that MYROBOT_gazebo should be replaced with your own package name, for example "eman_robot_gazebo". It seems the tutorial also requires some basic knowledge of how catkin and ROS work.

Comment by Eman on 2014-02-18:
Thanks a lot for your help. God bless you. Thanks also for your suggestion. I will re-do the tutorial with care of every thing & confirm basic knowledge of how catkin and ROS work.

$\endgroup$
0
$\begingroup$

Gazebo Answers logo

Have you run catkin_make in that workspace before launching?


Originally posted by Ben B with karma: 175 on 2014-02-17

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Eman on 2014-02-18:
Thanks for your help. God bless you. No,I have not run catkin_make in that workspace before launching.

Comment by Ben B on 2014-02-18:
Then try to run it and try to roslaunch again! I think the build process somehow alerts ROS to the presence of the package.

Comment by Eman on 2014-02-21:
Thanks a lot for your help. The problem had been solved.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.