0
$\begingroup$

Gazebo Answers logo

Hello everybody, I am experiencing another problem with gazebo. I am running a 64 bit Ubuntu 12.04 lts with ros hydro. After performing today's updates I tried to run the simulation I was working to and I got the following loading message

    gzserver: symbol lookup error: /opt/ros/hydro/lib/libgazebo_ros_api_plugin.so: undefined  symbol: _ZN3ros7console5printEPNS0_10FilterBaseEPN7log4cxx6LoggerENS0_6levels5LevelEPKciS9_S9_z
Msg Waiting for master.[gazebo-2] process has died [pid 8366, exit code 127, cmd /opt/ros/hydro/lib/gazebo_ros/gzserver /home/mago/Development/Repository/ROS/labrob_hydro_hetcont/src/ugv_gazebo/worlds/ugv.world __name:=gazebo __log:=/home/mago/.ros/log/6606f8d8-86ab-11e3-96db-8ca9821c9902/gazebo-2.log].
log file: /home/mago/.ros/log/6606f8d8-86ab-11e3-96db-8ca9821c9902/gazebo-2*.log

I thought was a problem of a plugin and I commented out all the plugins from the sdf file. However the problem is not solved.

I have found the following two questions but they did not solve my issue:

http://answers.ros.org/question/121266/undefined-symbol/ http://answers.ros.org/question/120541/problem-of-running-rosrun-turtlesim-turtlesim_node/?answer=120596#post-id-120596

Please help

EDIT: I noticed that the problem occurs only using roslaunch,


Originally posted by Andrea on Gazebo Answers with karma: 72 on 2014-01-26

Post score: 0


Original comments

Comment by Jose Luis Rivero on 2014-01-27:
What version of ros-gazebo-pkgs and gazebo are you using? Are you only using the ROS repository or you are also using packages.osrfoundation.org?

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

I write a new answer so other users can find it easily. As said by Jose the problem was the use of a mismatched gazebo version. This is what I did:

  1. removed from the software resources the repository http://packages.osrfoundation.org/gazebo/ubuntu

  2. udpate and upgraded the system

  3. Removed the package gazebo-current that implied the removal of the package ros-hydro-desktop-full

  4. installed again the ros-hydro-desktop-full package that installed the correct gazebo version.

Thanks for the help provided!

Bye Andrea


Originally posted by Andrea with karma: 72 on 2014-01-29

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Jose Luis Rivero on 2014-01-30:
Remember that this only a workaround, we will update the issue as soon as it is properly fixed.

Comment by Jose Luis Rivero on 2014-02-06:
It is now fixed, you should not need to remove OSRF repository.

Comment by Andrea on 2014-02-06:
I think I will stick with the current working version. Thank you anyway you have been really helpful!

Comment by PMilani on 2014-04-05:
Is there an actual fix to this? Or should it work with an upgrade. I have recently upgraded but now find that this error is interferring with my previously working roslaunch launches. Are there any further steps to be undertaken?

Comment by Andrea on 2014-04-06:
Depends on the version of gazebo you are using. Is it the one from the osrf repositories? Could you give some more details?

Comment by PMilani on 2014-04-06:
Its Gazebo 2.2.2, I thought it was installed when I installed hydro as 1.9.+. 'apt-cache policy', lists the osrf i386 and amd64 repositories. An apt-get upgrade bought it up to Gazebo 2.2.2.

Comment by Andrea on 2014-04-06:
Hi actually if you install Hydro from ROS repositories the last version is gazebo 1.9.5. You probably installed the version you have from the osrf repositories. Delete the osrf repo and install hydro + gazebo from ros repo. Follow the passages I wrote in the answer ;)

Comment by PMilani on 2014-04-06:
Thanks Andrea that worked, I'd not followed your directions as Jose indicated I shouldn't need to. But in fact it seems that roslaunch works with version 1.9.5 and not with 2.2.2

Comment by Andrea on 2014-04-06:
Happy to hear that you solved the problem :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.