0
$\begingroup$

Gazebo Answers logo

I just updated gazebo-prerelease through ubuntu(12.04) update manager from 1.9.4 to 1.9.5 and now gazebo cannot find the gasebo_ros plugins which were working well till now.


Error [Plugin.hh:127] Failed to load plugin libgazebo_ros_gpu_laser.so: libsdf.so.1: cannot open shared object file: No such file or directory Error [Plugin.hh:127] Failed to load plugin libgazebo_ros_diff_drive.so: libsdf.so.1: cannot open shared object file: No such file or directory


These were the only plugins I was using for you. I did a search for the plugins and found them in the ros simulator_gazebo stack for some reason. Adding them, to GAZEBO_PLUGIN_PATH doesnt solve the issue either.

ROS: Groovy


Originally posted by Shehzi on Gazebo Answers with karma: 21 on 2013-07-26

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

Try using the main gazebo debian (which is currently 1.9.0). This should work with gazebo_ros.


Originally posted by nkoenig with karma: 7676 on 2013-07-26

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Shehzi on 2013-07-26:
Works! with main debian. Had to install the gazebo_ros_pkgs from source once more to make it run. Thank you

Comment by evilBiber on 2013-07-29:
Hi,

I quess It all runs with the source install again if you update and rebuild gazebo_ros_pkgs too. libsdf.so has been replaced with libsdformat.so in the newest releases.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.