0
$\begingroup$

Gazebo Answers logo

As I had much problems with gazebo under fuerte I decieded to try out groovy with gazebo 1.3. But it won´t spawn a simple object.

    Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Warning [parser.cc:361] Converting a deprecated SDF source[/opt/ros/groovy/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world].
Set SDF value
  Version[1.2] to Version[1.3]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Msg Waiting for master.Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.2.4
[ INFO] [1364762386.117130304]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.2.4
[ INFO] [1364762387.522566147]: joint trajectory plugin missing <updateRate>, defaults to 0.0 (as fast as possible)
Error [ModelDatabase.cc:159] No <database> tag in the model database manifest.xml found here[http://gazebosim.org/models/]
Error [ModelDatabase.cc:211] Unable to download model manifests

The following command keeps running:

 rosrun gazebo spawn_model -file object.urdf -urdf -z 1 -model my_object
[INFO] [WallTime: 1364763933.932859] [0.000000] waiting for service /gazebo/spawn_urdf_model

I tried to convert the empy.world with gzsdf tool but I could not locate the tool..


Originally posted by Davinci on Gazebo Answers with karma: 65 on 2013-03-31

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

Hi,

make sure you sourced the setup.bash file:

/<path>/gazebo$ source setup.bash

then run in a terminal:

$ rosrun gazebo gzsdf convert /<path>/your.sdf

or

/<path>/gazebo$ ./gazebo/bin/gzsdf convert /<path>/your.sdf

(you may need sudo rights for converting the empty.world file, or you could just create another one in a different package)

!!!!Update!!!!

to spawn use:

$ gzfactory spawn -f /<path>/model.sdf -m model_name -x 1 -y 1 -z 2 -R 0 -P 0 -Y 0

Cheers, Andrei


Originally posted by AndreiHaidu with karma: 2108 on 2013-04-01

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Davinci on 2013-04-01:
I can find the plugin now but I can't convert the empty world. That does not seem to be the problem. I think spawn_model does not work anymore?

Comment by AndreiHaidu on 2013-04-01:
and why cant you convert the world file? that should also work, did you try it with sudo?

Comment by Davinci on 2013-04-01:
spawning works now thanks. Weird that I also had to source the gazebo setup,bash, this was not necessary in fuerte.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.