0
$\begingroup$

Gazebo Answers logo

This is for Gazebo 1.4, drcsim-2.1. Worth testing on Gazebo 1.5, drcsim-2.2

The simulation slows down as the robot is "driven" through a complex environment.

Here is a simple test everyone can do at home:

In terminal window #1

source /usr/share/drcsim-2.1/setup.sh
roslaunch atlas_utils vrc_task_1.launch

press 'run' and wait more than 10 seconds for the robot to become unpinned.

In terminal window #2

source /usr/share/drcsim-2.1/setup.sh
rostopic pub /atlas/set_pose --once 'geometry_msgs/Pose' '{position: {x: 3.0, z: 0.95}, orientation: {z: 0, w: 1}}'
rostopic pub --once /atlas/cmd_vel geometry_msgs/Twist '{linear: {x: 1}}'

On a dual Intel(R) Xeon(R) E5-2687W @ 3.10GHz with a Quadra 6000 and a Tesla K20 GPU: The simulation starts with the Real Time Factor around 0.92. By the time the robot reaches the first turn it has declined to 0.36.

On a i7-3770K @ 3.50GHz with a GTX 690 and another i7-3770K with a GTX 650 GPU: The simulation starts with the Real Time Factor around 1.0. By the time the robot reaches the first turn it has declined to 0.14.

There is no sign of any rebound of the Real Time Factor if I leave the simulation running, having stopped the robot motion.

This slowdown does not appear to happen when using our own walking code.


Originally posted by cga on Gazebo Answers with karma: 223 on 2013-03-12

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

I've noticed the exact same behaviour, and it's rather annoying when testing other modules/behaviours. You don't even need to drive it through a complex behaviour, the bug (?) also occurs when using just Atlas + empty world.

I opened a ticket about it a few days ago: https://bitbucket.org/osrf/gazebo/issue/564/cmd_vel-atlas-gliding-slows-down-gazebo


Originally posted by ThomasK with karma: 508 on 2013-03-12

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by hsu on 2013-03-16:
thanks for reporting. Seems to be a problem with joint destruction not cleaning up completely. Following up in the ticket.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.