1
$\begingroup$

I'm using the johnny-five library to control an Arduino Uno running StandardFirmata. I have a HC-05 bluetooth module that I want to use to wirelessly control firmata, but have yet to get it working.

I used http://www.instructables.com/id/Modify-The-HC-05-Bluetooth-Module-Defaults-Using-A/ to configure the board for 57600 baud rate: AT+UART=57600,0,0. I'm able to send various AT commands and read back the results in my serial monitor.

I followed http://www.instructables.com/id/Use-your-android-phone-sensors-on-the-arduino-/?ALLSTEPS to wire up the voltage divider, to make my Arduino's TX operate at 3.3 going into the HC-05's RX.

I've tried running the HC-05 in master, slave, and slave-loop. It only makes a BT connection in slave, which is default.

When I run my johnny-five script, here's the output:

± node jf-simple.js
1394412173445 Board Connecting...
1394412173447 Board -> Serialport connected
waiting for board to be ready
1394412273448 StandardFirmata A timeout occurred while connecting to the Board.
Please check that you've properly loaded StandardFirmata onto the Arduino
1394412273448 Board Closing: firmata, serialport

I've more-than-triple-checked everything. Uploaded firmata many times. Firmata works fine over USB. Also, I have been able to get this working in the past with an HC-06.

  • Am I missing something?
  • What are some good debugging techniques to figure out why it won't connect to Firmata?
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.