Gazebo Answers logo

Hi there!

I'm trying to get our Collada mesh properly visualised in Gazebo. After fixing the units, the mesh itself is correctly shown. However, the texture (a JPG file) is not correctly mapped onto the mesh.

The mesh + texture is properly visualised in MeshLab and RViz. I also tried loading my model via both URDF and SDF to make sure, this is not a problem of the URDF parser.

Here is a screenshot of both RViz and Gazebo visualisation: gazebo-collada-mesh-problem.png

Does anybody have an idea what's going wrong?

I found some similar looking bugs filled for Gazebo, but I'm not sure they are about the same problem. If there is already a bug filled for this, please let me know about it, so I can keep track of it.


I just received a comment from another Gazebo user, who has a similar looking issue:

I cannot comment your post because I have karma 1, but we have the same problems with textures since Gazebo 1.0. Up to the version bundled with ROS Electric everything worked just fine, then in 1.3 we get a marble-like texture very similar to yours, and in 1.4 textures are simply not shown. All other Collada viewers that we've tried (Blender, AssimpView, MeshLab, rviz) render the color maps correctly. Now that we know that with 1.4 it still does not work, we were also about to post a question. You beat us to it :). I'm attaching a picture of how things look like up to Gazebo 1.3 and Rviz.

Relevant package: http://www.ros.org/wiki/reem_description

And here is his picture: reem-gazebo-rviz.png

We thank for your help!

/edit #2:

Regarding iche's request:

My screenshot shows Kobuki (the mobile base for TurtleBot 2) and its meshes can be download from Github: https://github.com/yujinrobot/kobuki_description

/edit #3: The answer is buried in the comments, so I'm adding it here as well: @iche033 was right. The meshes look fine using Gazebo 1.5.

Originally posted by bit-pirate on Gazebo Answers with karma: 129 on 2013-02-20

Post score: 0


1 Answer 1


Gazebo Answers logo

Hi, is there a place I can download the model files and try them out?

Originally posted by iche033 with karma: 1018 on 2013-02-21

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by bit-pirate on 2013-02-21:
Hi iche! I know, you currently have no other choice, but in the future please use the comment function for comments. Thank you!

Comment by bit-pirate on 2013-02-21:
And to answer your question: To get the meshes, have a look at the packages reem_description and kobuki_description. I added the missing link to the latter in my question.

Comment by iche033 on 2013-02-22:
hi, the model loads fine for me https://www.dropbox.com/s/s1txxzjvhfomvzb/kobuki_a.png https://www.dropbox.com/s/3k7v4x8z27nfkdk/kobuki_b.png

This is from the development branch and not debs. There were some recent fixes to the collada loader but probably didn't make it into the last release, should be there in the next release.

Comment by bit-pirate on 2013-02-26:
Which version are you running? And do you have any idea, when this new release is going to happen? Also, will those fixes be release into Gazebo for ROS Groovy (currently 1.3)?

Comment by iche033 on 2013-02-27:
I compile from source using the default branch from bitbucket. Gazebo 1.5 is scheduled for release next friday on March 8th, that should load your textures. As for ROS Groovy Gazebo.. there is currently no release plan yet so I'm not sure what changes/version will go in...

Comment by bit-pirate on 2013-03-11:
Thanks @iche033! I'm eagerly awaiting the release of 1.5 for testing! Will report the results.

Comment by Adolfo Rodríguez T on 2013-03-12:
I can confirm that color maps are properly loaded in Gazebo 1.5. In 1.4 the specularity map was being shown instead. Thanks devs.

Comment by bit-pirate on 2013-04-03:
Finally got around to test this. @iche033 is right, the meshes look fine using Gazebo 1.5. Thanks for testing!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.