0
$\begingroup$

Gazebo Answers logo

In earlier ROS/Gazebo versions this:

<node name="spawn_robot" pkg="gazebo" type="spawn_model"
  args="-param robot_description
        -urdf
        -z 1.7
        -model robot_description"
  respawn="false" output="screen" />

would spawn a urdf model at position (0/0/1.7) in the gazebo world. This does not seem to be the case anymore with the current gazebo version installed from .debs in groovy. My robot model is always spawned to (0/0/0), which means it is severly clipping through the ground, in turn launching it into space every time I try to spawn it (or try to reset model poses, for that matter). Are there any known easy workarounds for that matter? Is the above methods of specifying a spawn position deprecated/unsupported now, or is the described behavior a bug?

As a side note, on startup, my gazebo says:

Gazebo multi-robot simulator, version 1.2.5

Looking at the changeset I would've expected to see 1.3.x , but apt-get says my .debs are up-to-date.

/edit: Wanted to test with Gazebo 1.3 from shadow-fixed repo. This does not currently work, however (see comments)

/edit: Just tested with Gazebo 1.3. The spawn height is honored there, unfortunately Gazebo instantly crashes with the semi-assembled robot floating in the air.


Originally posted by Stefan Kohlbrecher on Gazebo Answers with karma: 473 on 2013-01-21

Post score: 2


Original comments

Comment by jamuraa on 2013-01-21:
The answer to your 1.2.5 / 1.3.x question is that groovy was released in December 2012, so it has version 1.7.6 of that changelog - which is 1.2.5. 1.3 was switched to in 1.7.7

Comment by hsu on 2013-01-22:
1.7.8 is still in shadow fixed, you can wait until it gets sync'd with the public repo, or If feeling adventurous, you can set your /etc/apt/sources.list.d/ros-latest.list to

deb http://packages.ros.org/ros-shadow-fixed/ubuntu precise main

sudo apt-get update

sudo apt-get dist-upgrade

Comment by Stefan Kohlbrecher on 2013-01-24:
I'm always feeling adventurous ;) Tried as you suggested, unfortunately the adventure comes to a sudden halt due to gazebo (or better, rospack) always complaining on gazebo startup: "[rospack] Error: stack/package simulator_gazebo not found". "roscd simulator_gazebo" works, however.

Comment by Stefan Kohlbrecher on 2013-01-24:
Guess I'll wait a little and see if this is just a temporary hiccup in the shadow-fixed repo.

Comment by hsu on 2013-01-24:
I've found myself in the

simulator_gazebo not found

state before too. It seems to be because of some bash issue, failing to handle ros environment states properly. Do you still get the same problem if you try things out in a new terminal?

Comment by Johannes Meyer on 2013-01-24:
Could be a problem with the rospack cache stored in ~/.ros. ROS does not differentiate between releases. I had similar problems when switching between fuerte and groovy with the same packages at different locations. Deleting rospack_cache or setting ROS_HOME explicitly usually solves the problem.

Comment by Stefan Kohlbrecher on 2013-01-25:
Just created this Q/A: http://answers.gazebosim.org/question/1056/rospack-error-stackpackage-simulator_gazebo-not/ before seeing Johannes's suggestion ..trying it out.

Comment by Stefan Kohlbrecher on 2013-01-25:
Nope, doesn't work. Everything else related to the rospack error should go into the newly created Q/A.

Comment by hsu on 2013-01-25:
thanks for looking into this Stafan.

Comment by hsu on 2013-07-23:
updated groovy uses gazebo 1.5, can someone please test and report? Thanks!

Comment by Johannes Meyer on 2013-07-24:
@hsu: Seems to work with ros-groovy-simulator-gazebo 1.7.12 and gazebo 1.5 as of today.

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

rospack issue resolved, see (as linked before) http://answers.gazebosim.org/question/1056/rospack-error-stackpackage-simulator_gazebo-not


Originally posted by Stefan Kohlbrecher with karma: 473 on 2013-01-25

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.