0
$\begingroup$

Gazebo Answers logo

I have the DRCSim installed following the instructions given on the page http://gazebosim.org/wiki/InstallDRC I run gazebo fom the terminal and the GUI opens but when i try to load the robot Atlas into it, it gets stuck and says the following error.

Error [gazebo_ros_laser.cpp:153] Not loading plugin since ROS hasn't been properly initialized.
Try starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

[ INFO] [1358375724.736451441]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.736598690]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.736685301]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.736775527]: Camera plugin missing , defaults to 0

Error [gazebo_ros_camera_utils.cpp:234] Not loading plugin since ROS hasn't been properly

initialized. Try starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

[ INFO] [1358375724.791922002]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.791974926]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.792008562]: Camera plugin missing , defaults to 0

[ INFO] [1358375724.792041779]: Camera plugin missing , defaults to 0

Error [gazebo_ros_camera_utils.cpp:234] Not loading plugin since ROS hasn't been properly

initialized. Try starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

Error [AtlasPlugin.cc:135] r_foot_contact_sensor not found

Error [AtlasPlugin.cc:144] l_foot_contact_sensor not found

Error [AtlasPlugin.cc:159] Not loading plugin since ROS hasn't been properly initialized. Try

starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

Error [gazebo_ros_joint_trajectory.cpp:108] Not loading plugin since ROS hasn't been properly

initialized. Try starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

Error [gazebo_ros_controller_manager.cpp:127] Not loading plugin since ROS hasn't been properly

initialized. Try starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

[ INFO] [1358375727.052850892]: imu plugin missing , defaults to /default_imu

[ INFO] [1358375727.052919510]: imu plugin missing , defaults to 0s

[ INFO] [1358375727.052961251]: imu plugin missing , defaults to 0s

Error [gazebo_ros_imu.cpp:124] Not loading plugin since ROS hasn't been properly initialized. Try

starting gazebo with ros plugin:

gazebo -s libgazebo_ros_api.so

I have been using gazebo for 2 weeks and it was working fine. I have this problem from only today, now I am not able to run this world as well

roslanch atlas_utils atlas.launch

It loads and then just dissappears.

Can someone please help me .

THank YOu


Originally posted by Bharadwaj Ramesh on Gazebo Answers with karma: 51 on 2013-01-16

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

I have the same error on code with two cameras that used to work with no errors. I run roscore, and then gazebo world:

Gazebo multi-robot simulator, version 1.3.1
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.3.1
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345

Msg Connected to gazebo master @ http://localhost:11345
Warning [ModelDatabase.cc:93] GAZEBO_MODEL_DATABASE_URI not set
Warning [ModelDatabase.cc:93] GAZEBO_MODEL_DATABASE_URI not set
Warning [ModelDatabase.cc:137] Unable to connect to model database using [/]. Only locally installed models will be available.
Error [gazebo_ros_camera_utils.cpp:234] Not loading plugin since ROS hasn't been properly initialized.  Try starting gazebo with ros plugin:
  gazebo -s libgazebo_ros_api.so
Error [gazebo_ros_camera_utils.cpp:234] Not loading plugin since ROS hasn't been properly initialized.  Try starting gazebo with ros plugin:
  gazebo -s libgazebo_ros_api.so

Executing

gazebo -s libgazebo_ros_api.so

with no world file argument leads to

Gazebo multi-robot simulator, version 1.3.1
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Error [Plugin.hh:126] Failed to load plugin libgazebo_ros_api.so: libgazebo_ros_api.so: cannot open shared object file: No such file or directory
Gazebo multi-robot simulator, version 1.3.1
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345

Msg Connected to gazebo master @ http://localhost:11345
Warning [ModelDatabase.cc:93] GAZEBO_MODEL_DATABASE_URI not set
Warning [ModelDatabase.cc:93] GAZEBO_MODEL_DATABASE_URI not set
Warning [ModelDatabase.cc:137] Unable to connect to model database using [/]. Only locally installed models will be available.

roscore starts up with the following errors:

... logging to /home/cga/.ros/log/a6b2c846-60c6-11e2-9f20-0014225a80ab/roslaunch-cga2-2011.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is ignored process[master]: started with pid [2027] ROS_MASTER_URI=http://cga2:11311/ setting /run_id to a6b2c846-60c6-11e2-9f20-0014225a80ab Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in ignored process[rosout-1]: started with pid [2040] started core service [/rosout] --- Originally posted by [cga](https://answers.gazebosim.org/users/66/cga/) with karma: 223 on 2013-01-17 This answer was **ACCEPTED** on the original site Post score: 1
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.