0
$\begingroup$

Gazebo Answers logo

I'm trying to get rid of any shadow effects in Gazebo and DRCSim-1.3.1. I understand the sun causes most of the shadows and is explained here. When I uncheck "cast shadows" in the Scene, the shadow is removed from the ground. However, when I try to uncheck "shadows" for the sun or any model. The shadows are not removed from the model at all.

I also tried to place more lighting around the model to reduce the effect of the shadows. Sometimes the shadows are removed, and sometimes they are not. However, when I use the simple camera model explained here. The captured images do not reflect the current scene.

Is there anyway to ensure models do not cast shadows on themselves and the world?


Originally posted by astaranowicz on Gazebo Answers with karma: 51 on 2013-01-15

Post score: 4

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

You should be able to add/remove all shadows using the scene tag in your world file.

...
<world name="default">
  <scene>
    <ambient>0.0 0.0 0.0 1.0</ambient>
    <shadows>0</shadows>
  </scene>
...

If there is a light source (such as the sun) in your world, you may end up with a light side and a dark side to your model. This is not so much a shadow, but a lack of light. If this is not the desired outcome, you have a few options at this point:

  1. Add more light sources to get the coverage that you desire
  2. Remove all light sources and add ambient light to your scene (change the above values from 0.0 to 0.5) although with this option you seem to lose the textures on your models

Originally posted by david_rusbarsky with karma: 111 on 2013-01-16

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by astaranowicz on 2013-01-21:
Still a problem that adding most of the lighting to the scene to reduce the dark side effect. The camera jpeg images do not reflect the current scene's lighting changes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.