Gazebo Answers logo

Hey guys,

I've been having problems starting drcsim/gazebo ever since I updated a few ros-fuerte packages back in December (around the 17th). Back then, I was using gazebo 1.3 and the drcsim 1.2, and now with drcsim 1.3.1 I still get the same error:

Error [Transport.cc:102] Unable to get topic namespaces in [50] tries.
Error [Node.cc:76] No namespace found

I've searched through gazebo answers, bitbucket and so on (look at the end for links), but while most of the problems seem related to graphics drivers (raising exceptions with X server), mine does not raise any exceptions or gives any clue about what the error might be (look at the end for a link to the complete output). It does seem to be related to ogre or qt, since it does not even initialize the window.

I've tried reinstalling drivers, removing all ros-fuerte packages and installing them again, removing gazebo and drcsim and installing them again, and the same thing with ogre related packages. I've also tried doing a fresh install of ubuntu 12.04 and everything on this machine (I thought maybe the kernel had been updated and somehow it broke some packages) and simply following these steps:

# install ubuntu 12.04, without any updates
sudo apt-get install nvidia-current
# add ros/gazebo servers to sources
sudo apt-get install drcsim

But it did not work as well, with the same error and everything. The ros server still runs in the background, it's just that gazebo shows that message and then quits without ever bringing up its window.

Anyway, I'm hoping someone has a clue about what is happening. FYI, my graphics card is a GeForce 9800 GT, and glxinfo shows no problems I think (direct rendering: yes).

Here are the links to other related posts:

Here is the link to gazebo output: http://pastebin.com/3Cgwrwix

Originally posted by Felipe Bacim on Gazebo Answers with karma: 16 on 2013-01-08

Post score: 0

Original comments

Comment by Felipe Bacim on 2013-01-09:
Forgot to mention that rviz works fine, so if it is a problem with ogre/qt, it's in the combination of ros-fuerte, gazebo and those libraries.

Comment by hsu on 2013-01-10:
can you try:

source /usr/share/drcsim/setup.sh


and see if gazebo itself starts up?

Comment by Felipe Bacim on 2013-01-10:
Yes, here it is: http://pastebin.com/EZsDhwdu

Same error without the exceptions and warnings.

Here is the logfile that is generated when I run the drcsim: http://pastebin.com/eEhRTTX9

It might be useful since it shows all the env variables and so on.


1 Answer 1


Gazebo Answers logo

The Gazebo output you have posted through pastebin indicates some serious issues. It looks like you don't have a properly configured system. You should not have any Exception errors when ROS starts. The same is true for all the warning messages.

I check to make sure you have ROS and Gazebo properly installed, and you've sourced the correct setup.sh files.

Originally posted by nkoenig with karma: 7676 on 2013-01-09

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by Felipe Bacim on 2013-01-09:
The exceptions seem to be a python bug, and according to http://answers.ros.org/question/34304/exception-attributeerror-when-starting-roscore/ it should not be an issue. I followed all the steps in http://gazebosim.org/wiki/InstallDRC and I'm sourcing /usr/share/drcsim/setup.sh as specified there.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.