0
$\begingroup$

Gazebo Answers logo

Hi,

I'm following the tutorial "Tutorials/1.2/ros enabled model plugin" in order to enable the plugins with ROS, but I have problems when I try to build the code. The CMake throw the following error:

-- The C compiler identification is GNU 4.7.2

-- The CXX compiler identification is GNU 4.7.2

-- Check for working C compiler: /usr/bin/gcc

-- Check for working C compiler: /usr/bin/gcc -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Check for working CXX compiler: /usr/bin/c++

-- Check for working CXX compiler: /usr/bin/c++ -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")

-- checking for module 'gazebo' -- package 'gazebo' not found

CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message): A required package was not found

Call Stack (most recent call first): /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal) CMakeLists.txt:5 (pkg_check_modules)

Cached location of rospack is invalid; searching for rospack... -- Configuring incomplete, errors occurred!

I'm quite new using CMake and the sintax is too complex for me. I don't know why is not finding gazebo package. I'm using ROS Groovy and Ubuntu 12.10. PD. Sorry I don't know how to give the format to my text.

Thanks in advance.


Originally posted by raulpl25 on Gazebo Answers with karma: 1 on 2013-01-07

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

It looks like you don't have Gazebo installed. We're only making binary packages for Ubuntu 12.04 at the moment, so you'll need to build from source.


Originally posted by gerkey with karma: 1414 on 2013-01-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.