0
$\begingroup$

Gazebo Answers logo

Hi,

The simulation does not visualize the mesh of a robotic hand model in Gazebo 1.2.5, which under Gazebo 1.0.2 worked fine.

The URI to the .dae file is correct in the sdf (v1.2) file. (I tried it with another .dae file from PR2 and it visualized it).

The difference between the files was that mine had COLLADA version 1.4.0, and PR2 had version 1.4.1. So I imported it in Blender and exported it as version 1.4.1 and it still did not work.

Here is my original .dae file, here it is after converting it in 1.4.1 and this is a PR2 .dae file which works.

Any ideas?

Thanks, Andrei


Originally posted by AndreiHaidu on Gazebo Answers with karma: 2108 on 2012-12-12

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

It looks like the collada file has incorrect units. Open up your original dae file, and go to this line:

<unit meter="0.01" .../>

Change to `meter="1.0"'


Originally posted by nkoenig with karma: 7676 on 2012-12-12

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by AndreiHaidu on 2012-12-13:
It worked, thanks a lot.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.