0
$\begingroup$

Gazebo Answers logo

I have a simple robot with four links and four revolute joints. The first joint is pinned to the world. When I run the simulation, the robot is not affected by gravity. I know gravity is enabled because when I drag another object like a box and drop it into the world, it falls down. I suspect that gravity is not affecting my four-link robot because it is pinned to the world. Could this be the case? How can I enable gravity for my robot?

Update: The problem was fixed by specifying collision elements for each link in the robot. This is strange since collisions and dynamics should be decoupled. Should this be considered a bug?


Originally posted by liangfok on Gazebo Answers with karma: 21 on 2012-11-08

Post score: 2


Original comments

Comment by hsu on 2012-11-12:
can you post your robot model? (with and without collision bodies?)

Comment by hsu on 2012-11-30:
can you change your question's title to reflect the issue? i.e. dynamics disabled if missing collision element? thanks.

$\endgroup$

2 Answers 2

0
$\begingroup$

Gazebo Answers logo

It appears if a model does not have any collision elements, it behaves statically, ticketed here.


Originally posted by hsu with karma: 1873 on 2012-11-30

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by scpeters on 2013-01-11:
This issue has been resolved.

Comment by scpeters on 2013-01-11:
This issue has been resolved.

$\endgroup$
0
$\begingroup$

Gazebo Answers logo

Creating a joint between a model and the world (aka pinning the model to the world), will enforce a joint constraint between the robot and world. This is usually only used if you want to the robot to remain in on fixed location.

I think you may have pinned the robot, and it looks like gravity is not working because the joint is just holding the robot in place.


Originally posted by nkoenig with karma: 7676 on 2012-11-09

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.