0
$\begingroup$

Gazebo Answers logo

Hello All,

I've just installed gazebo 1.2. All went well, i like the look of the GUI(don't use it though). After some struggling with the new SDF syntax (the converter did not work for me, but i like the syntax), I started very basic world with just the groundplane and the sun model included.

The simulation runs at 0.97X(at best) realtime using 100% on all four cores (intel i7 quadcore clocked at 4.ghz, 6GB ram, Ubuntu 12.04 32bits, Radeon 6870). On version 1.0.2 it ran in excess of 25X realtime using the same solver settings and a more challenging world. Quite dissapointing, is this a common problem? What might be the reason?

Apart from that, what is up with the new file/model structuring system(`database')? I understand a uniform folder and naming structure is useful for sharing etcetera. However I don't feel the need to have this restriction locally. Does every model(file) have to be called model.sdf and include a manifest.xml? E.g when editing (gedit) two models, i cannot tell them apart by their filename which is fairly annoying. Is there a way to circumvent this?

Thanks


Originally posted by Erik Stoltenborg on Gazebo Answers with karma: 86 on 2012-11-07

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

Hello,

Gazebo 1.2 throttles itself to about 1.0 real-time. You can change this using the update_rate SDF parameter. When the update_rate = 1/dt, which is the default, then Gazebo runs at realtime. Set the update_rate = 0 and Gazebo will run as fast as it can.

The next major release of Gazebo has better sleep behavior, and will not use 100% of your CPU.

The model database format is not necessary, and you don't have to name everything model.sdf. Gazebo does use URIs for everything, as described here. So you can use file://path_to_my_model.sdf.


Originally posted by nkoenig with karma: 7676 on 2012-11-07

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Erik Stoltenborg on 2012-11-08:
Great, that just about solved all my issues! Gazebo now runs multithreaded, nice (at least i did not notice load on all four cores in 1.0.2).

Comment by Erik Stoltenborg on 2012-11-08:
I'd be great if the sleeping behaviour would be better. I'm by no means good programmer,so forgive me if its stupid,but would using conditions not be better than using while loops in the throttling (in e.g. world::runloop() just changes a condition value on which e.g. world::update waits if needed)?

Comment by Erik Stoltenborg on 2012-11-08:
Ok i just tested this the URI thing, i can't get it to work. I tried absolute paths, relative paths (even model://file:// like the error suggested). All result in error: Directory doesn't exist, to be exact: Error [parser.cc:557] Directory doesn't exist[/home/bla/bla/table.sdf].

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.