0
$\begingroup$

Gazebo Answers logo

Hi, I'm trying to create an outdoor world using a mesh file that I downloaded from Google SketchUp library and then exported to DAE using Google Sketchup. I am getting this error:

Error [SystemPaths.cc:262] cannot load file [mountain.dae]in GAZEBO_RESOURCE_PATH[/home/sameer/ros/falkor_quadrotor/falkor_quadrotor_gazebo/worlds:/opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds:/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/share/gazebo]
Error [MeshManager.cc:150] Unable to find file[mountain.dae]
Segmentation fault (core dumped)

the file mountain.dae is in /home/sameer/ros/falkor_quadrotor_gazebo/worlds

I'm loading it in with my world file like this:

   <model name="ground_model" static="true">
      <link name="ground_link">
        <origin pose="0 0 0 0 0 0"/>
        <collision name="ground_collision">
          <geometry>
            <mesh filename="mountain.dae" />
          </geometry>

I've tried using package://falkor_quadrotor_gazebo/worlds/mountain.dae as the filename as well but that also gave me an unable to find/core dump error.

I have since hardcoded the pathname and now I'm getting this error:

Error [ColladaLoader.cc:66] Unable to load collada file[/home/sameer/ros/falkor_quadrotor_gazebo/Media/models/mountain.dae]
Error [ColladaLoader.cc:70] Missing COLLADA tag

As noted earlier, I saved this file using SketchUp. I looked at the file and there is a COLLADA tag right there in the beginning:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<COLLADA xmlns="http://www.collada.org/2005/11/COLLADASchema" version="1.4.1">
    <asset>
        <contributor>
            <authoring_tool>SketchUp 8.0.15157</authoring_tool>
        </contributor>
        <created>2012-10-10T02:20:37Z</created>

Thanks.


Originally posted by Sameer Parekh on Gazebo Answers with karma: 1 on 2012-10-16

Post score: 0


Original comments

Comment by mcevoy.andy on 2012-10-23:
I remember having the same trouble... I want to say it had to do with the <gazebo gazebo _ media _ path=${prefix}"/> line in the manifest.xml file, but it has been too long now. I also still have trouble with plug-in paths and find myself just hard coding the path into my files.

Comment by Sameer Parekh on 2012-10-25:
I actually hardcoded it (well I used $(find package)) and that didn't work either. I also tried package://etc/filepath I think.. Will try some other ideas.

Comment by nkoenig on 2012-10-30:
Only ROS uses the "package://" URI. Gazebo uses either "file://full-path-to-mesh" or "model://name-of-model-in-modeldatabase/meshes/my-model-file.dae"

$\endgroup$

1 Answer 1

0
$\begingroup$

Gazebo Answers logo

Only ROS uses the "package://" URI. Gazebo uses either "file://full-path-to-mesh" or "model://name-of-model-in-modeldatabase/meshes/my-model-file.dae"


Originally posted by nkoenig with karma: 7676 on 2013-01-11

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.