1
$\begingroup$

I followed the tutorial to display a robot arm in RViz. However, Rviz displayed nothing until I enable the "show robot collision" feature in MotionPlanning-Scene Robot

Can anyone tell me how to fix this issue?

My OS: Ubuntu 20.04

ROS: ROS1 Noetic

When I followed the tutorial, what I got was just a ball enter image description here

When I enable the "show robot collision" feature, I got a red robot_arm 3D model enter image description here

This is the tutorial result. A white robot arm. enter image description here

$\endgroup$
2
  • $\begingroup$ I solved this problem by downgrading Ubuntu to 18.04 and reinstalling ROS. So, I guess the issue was caused by "new rules". You have to provide more information about your robot arm so Rviz can display the whole model. $\endgroup$
    – Carlos
    Jul 10, 2023 at 7:27
  • $\begingroup$ Your comment should be posted as an answer $\endgroup$ Apr 1 at 6:49

2 Answers 2

0
$\begingroup$

The collision visualization is of simpler low polygon forms used for faster collision avoidance. What you're expecting to see and not seeing are the meshes for the visualization of the robot arm. To that end I don't know why they're not rendering, but it's likely that you are missing a dependency which is providing those meshes as resources. I would suggest double checking that you've installed all the prerequisite dependencies for that tutorial. And double check your environment setup.

$\endgroup$
0
$\begingroup$

Maybe it's because you didn't publish `joint_state?

Rviz2 display model is based on subscription to topic like joint_state_publisher.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.