I'm using Jammy and Humble and Nav2. The robot is beginning to do waypoint following and driving on his own. However, sometimes the Nav2 program is making black dots, as obstacles, appear where there were none on the map provided. The area was clean white. The floor is carpet, and apparently the laser is seeing something? It's a Velodyne puck, and I understand only one scan laser is in use in Nav2, of the 16 in the unit. Is there a setting I can adjust to stop the mapping/navigation from finding and developing these obstacles in robot's way?


1 Answer 1


check your sensor outputs for noise. Things don't just appear without reason. It might be necessary for your to lightly filter the output of your sensor data if you're noticing erroneous measurements that are causing a problem. The laser filters package might be useful for you to look into and are commonly used to model and remove common sources of laser scanner noise.


  • $\begingroup$ Thanks, Steve. Is there a setting on Slam Toolbox that would help the Velodyne overlook the two antenna that are in its way? If we could set a minimum distance to actively scan, say? I wonder if these are bothering the lidar? I noticed that the trouble decreased when I reduced scan rotation from 600 to 300 rpm. Where is this laser filters package you speak of? In Nav2? $\endgroup$
    – Russ76
    Mar 24 at 2:52
  • $\begingroup$ Check out the laser filters. I believe one there will do it for you with configuration. $\endgroup$ Mar 28 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.