I am using a supercomputer (MSI, Minnesota Supercomputing Institute) to run my Webots simulations. However, on my own laptop (MacOS) the amount of time necessary to calculations is much shorter. I was wondering if there was an optimal configuration (i.e., minimum number of cores, memory, etc.) that I should have to limit performance issues due to computation time?

Right now, I have allocated 25 GB of memory, 48 GB of temporary memory, and 8 cores on the supercomputer using the same environment as my Mac.

Info regarding this computer found below:

  Model Name:                 MacBook Air
  Model Identifier:           MacBookAir8,2
  Processor Name:             Dual-Core Intel Core i5
  Processor Speed:            1.6 GHz
  Number of Processors:       1
  Total Number of Cores:      2
  L2 Cache (per Core):        256 KB
  L3 Cache:                   4 MB
  Hyper-Threading Technology: Enabled
  Memory:                     8 GB

Any insights into how to limit this problem would be greatly appreciated!


1 Answer 1


It is very likely that your supercomputer has no GPU whereas your laptop has a GPU with OpenGL hardware acceleration. Webots relies a lot on the GPU, in particular for rendering camera images, lidars data, range-finder images, etc. If your simulation makes use of such devices, the performance will be impacted greatly if the supercomputer doesn't have any GPU.

In any case, you should be careful to launch Webots with the --no-rendering command line option to avoid rendering the main 3D view. This will speed-up your simulation. Also, you should use the --mode=fast option to ensure the simulation runs as fast as possible.

With these command line options and if your simulation is not using any GPU-related devices, it should normally run faster on the supercomputer.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.