0
$\begingroup$

The provided sample simulations are running very slowly in Webots. How can I improve this?

I am using Webots R2022b on Ubuntu 22.04.

$\endgroup$

1 Answer 1

0
$\begingroup$

Did you check if your graphics driver are installed correctly and up-to-date?

You can find some instructions to verify the graphics driver installation for Webots here. Note that it is recommended to run Webots on computers equipped with recent NVIDIA or AMD graphics cards.

You might also try other tweaks to speed up your machine:

  • on laptop computer you should check the power options and make sure to use the high performance power plan
  • disable the Ubuntu desktop animations (from the "Accessibility" section in the Settings app) that could use ample system resources, especially on older computers, and cause a huge performance drop of the rendering system.settings
$\endgroup$
1
  • $\begingroup$ If running Webots inside a virtual machine, I would recommend VMware Workstation Player over VirtualBox as it provides a significantly better OpenGL hardware acceleration when enabled. Also, when running Webots in a Docker, you should ensure you are using the official Docker images, or derive your custom Docker image from the NVIDIA opengl image and obviously run it on a machine equipped with a NVIDIA card. $\endgroup$ Nov 23, 2022 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.