0
$\begingroup$

I am new to ros2. When I try to run a launch file, I get this message.

selected interface "interfaceName" is not multicast-capable: disabling multicast

I get this message when I use galactic, but when I use dashing I'm not getting this error.

Is there a possibility to disable this message?

Environment
Docker image: Ubuntu20
Ros2 Distro: galactic

Thanks a lot!

$\endgroup$
1
  • $\begingroup$ why is the message a problem? $\endgroup$
    – jsotola
    Jan 28 at 22:42

1 Answer 1

1
$\begingroup$

I'm not sure, but I suspect the message is coming from the RMW implementation. The default RWM implementation for Galactic (rmw_cyclonedds) is different from the default in Dashing (rmw_fastrtps_cpp). You could try setting the environment variable RMW_IMPLEMENTATION to try a different RMW before launching, e.g.:

export RMW_IMPLEMENTATION=rmw_fastrtps_cpp

Note, this changes the underlying communication library; you should set this variable in all terminals that are starting ROS nodes, otherwise you may run into issues with nodes communicating with each other. For more details about changing the RMW, see Working with multiple ROS 2 middleware implementations.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.