1
$\begingroup$

I am trying to simulate a drone inside an environment with constant wind. I have found a good plugin (link below) and I have done the following to integrate this plugin in my system:

  1. include the gazebo_wind_plugin.cpp file in my src folder
  2. include the header file (gazebo_wind_plugin.h) in the include folder
  3. edit the CmakeLists.txt to include this plugin

https://github.com/PX4/PX4-SITL_gazebo/blob/master/src/gazebo_wind_plugin.cpp

However, I get errors during catkin_make showing the following:

enter image description here

How should I install/integrate physics_msgs? Kindly advice if any other issue is present.

$\endgroup$
1
  • $\begingroup$ Please edit your post to have a copy and paste of the error, not a screen shot. That's not searchable or able to be copy and pasted. Please also include the full output with the input command, with just a snippet it's hard to confirm it is the root cause. $\endgroup$
    – Tully
    Commented Dec 23, 2021 at 19:12

1 Answer 1

3
$\begingroup$

You don't have to compile these files with your plugin. You should include the already existing wind plugin in to your world file. Check this example file and how you should use the wind plugin. The Gazebo physics will be on charge of applying the wind to your drone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.