I installed ROS Noetic on Ubuntu Mate 20.04 in my Raspberry Pi but couldn't find any specific tutorial to follow along for Noetic. Most are available for Melodic, which doesn't work with the latest one.

I tried following with one of JdeRobots guides: https://github.com/JdeRobot/drones

But the following command doesn't seem to work:

sudo apt-get install ros-noetic-jderobot-drones


Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-noetic-jderobot-drones

I want to do Drone Development using Noetic, but there's not much I could find specific for Noetic or I could convert old commands to. I tried searching Github repos but they aren't specifically for Noetic.


1 Answer 1


It appears that the package you're looking for is available in noetic: https://index.ros.org/p/jderobot_drones/#noetic

If you're getting that error it's likely that you have not setup the ROS package sources: http://wiki.ros.org/noetic/Installation/Ubuntu#Installation.2FUbuntu.2FSources.Setup_your_sources.list

If you are still having trouble please edit your question to add more information about how you setup your system. To help you most effectively, how to reproduce your problem is important to share.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.