2
$\begingroup$

I recently purchased at EY-80 from electrodragon: EY-80 All in one 9-Axis Motion Sensor (Gyro + Acceler + Magneto + Baro)

I am having a hard time compiling the example code on my arduino:

enter image description here

This is what is happening. So far, I am only copy and pasting the code. Any help? (I am somewhat new to programming, so don't fully understand all of the code)

$\endgroup$
  • $\begingroup$ Welcome to Robotics Toozinger. It is better to copy and paste the text of an error message than to take a screenshot, since we can't see the whole of the error message. Without more information we can't really help you, but I would initially suggest that you start by compiling the whole project as is, and only start cutting and pasting code from the project once you are familiar with compiling it. $\endgroup$ – Mark Booth Nov 25 '13 at 12:13
  • $\begingroup$ Thanks for the tip. I did get it working after correcting my library errors. $\endgroup$ – Toozinger Nov 25 '13 at 18:00
1
$\begingroup$

After talking to a friend, I found out what I did wrong.

  1. I needed to include all of the #include libraries.
  2. I downloaded one of the libraries in html, instead of raw .h format which was messing up the program, so I downloaded the correct version.

The program is now working, and collecting data well!

If you find your readings to be off, change the update delay from 500ms to 20ms and the readings will drastically improve.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.